LR V3 SKR Pro, Dual End Stop Z Homing Issue

Hi all.

Just recently wired up my new Lowrider V3 build using the SKR Pro 1.2 board. X and Y axis homing are working normally, but the Z axis will always run into one side or the other and start skipping.

  • Both end stop LEDs light up on the board when the switches are pressed.

  • M119 shows both switches triggered when manually depressed.

  • During homing, if i press one switch or the other, that side will stop as long as the switch is hit, but hitting both won’t trigger the “second stage” of homing.

  • In the touch screen menu, i had mild success by turning on an auto Z leveling setting. The side that hits the switch last will still skip a few steps before stopping.

    • This has intermittent success

Ive tried reflashing and a bunch of other things. It doesn’t appear to be the same issue that requires the resister but i could be wrong.

Anything else I can try? Maybe I am missing something obvious.

Are the end stops down far enough? So that the end stops are hit before the z height is maxed out

They should be, I left them all or at least most of the way down on the slots. Ive been cycling them manually during the homing process with no success.

I had a similair issue when building mine, but it mostly missed the end stops. I bended the leg on the endstops trigger a little which solved it for me.

Does it not skip steps when manually jogging it up and down?

No skipped steps as far as I can tell. Everything runs smooth otherwise.

Try to manually jog the Z axis to the top of the travel (1mm at a time when you get close), then do a M119 to see if the end stop switches are actually being activated.

I can try that after work.

They independently read as triggered when i manually actuated them and ran M119.

I also ran an M119 after a failed homing test (i hit the reset button when it started skipping) and both end stops came up as triggered afterwards.

I think you might have your endstops wired as normally open instead of normally closed

I don’t believe so. They operate normally when manually hitting them. The outer pins are being used on the end stops and they are plugged into the correct pins on the board.

Again, m119 shows them registering correctly both ways.

Well, I ordered a new board, swapped it in and flashed it, now it works perfect. Case closed!

1 Like