LowRider v3 Z axis drop / falls

My LowRider v3 drops if the core with the makita router is on the left side while homing. (Right side did. drop one time but can’t reproduce it)

It seems like the makita router has too much weight for this little Nema stepping motor? (Have bought the hardware Bundle from V1E)

This error occurs repeatedly on the left side while homing.


It doesn’t occur if the makita router is on the right side. But if it’s on the right side you can hear that the left side is loosing steps but the EndStop is already triggered (You can hear the loosing of steps at 0:34):


The only time I’ve had similar issues, was when my end stop wiring was loose. I would double check all your connections from the switch to the board to make sure nothing is loose.

Are your Z steppers on one driver, or two?

Additionally, if you haven’t lubed your lead screws, do that. Also check for any binding on your linear rails, as that can make the steppers work harder than they should.

1 Like

Ive recorded a step by step Video how to reproduce the error (please view it in HD quality on YouTube itself)

1.) Start & Home all axis: success
M119 works

2.) Start recommended Squareness Test
(1:22 -4:20, you can skip this test)

3.) Home again: error on left side
M119 does not work!
(Minute 4:47 in the video)

It shows the red end stop light on the SKR 1.2 board like it should!

But the software itself doesn’t recognise the triggered Endstop via M119!

Sometimes if I restart it works again.
But sometimes it doesn’t and I have to restart again.

How is it possible that the board shows a red light but the endstop via M119 isn’t triggered???

Any suggestions?

1 Like

I know some people had trouble in the past with SKR boards and LEDs causing some sort of problem:

I had a RAMBo board on my last build, and didn’t have that same issue, but I would read through that thread, as it may contain some solutions.


Thank you! Your post led me to this post:

Will try it tomorrow

1 Like

It worked!
I used 1,5k Ohm resistors.

Well my soldering skills are not the best and it was a bit of a hassle, but anyway it’s working now and the error is gone!

Thank you, I’ve could never come up with this solution!
Bigtreetech should really fix this in production, my batch is produced 02.2023, I’ve read that @Ryan has connections, maybe he could push a fix to the manufacturer?


I’m glad that resolved it. I’m building a new LR3 with an SKR, and am now just going to anticipate having to do this to avoid endstop issues.

1 Like

Well shoot, I thought we had moved past this. I will see if I can put it in their ear again.

1 Like

I also have this problem with the board, are they not going to replace the faulty boards?

Since I’ve purchased it from aliexpress in china and this fault seems to persist since 1 year, I’ve never tried it. Another solution would be to „kill“ the LEDs on the board, which could have been done quicker, if you’re interested in doing so.

Since the fix with the resistors I’ve never had any problem.


Cool thanks, is it just simply a matter of soldering resistors like you did, looking at the picture, or is there anything else done behind the scene? :slight_smile:

Found the LEDs useful to look at when testing Endstops, my case is transparent. Am planning to do the resistor trick if/when encountering this problem.

To fix it I only soldered the resistors, nothing more.

I wanted to keep the led intact, because otherwise I would feel like having a defect board & they are useful for me to indicate the endstops.

1 Like

Thanks so much for sharing the fix. Mine is running good now! :slight_smile:


Looks like the second try did it. They said they will be updating the resistor values! I know that doesn’t help you all but because of your issues and fixes new users won’t have this issue.


finally. I have been dealing with them for a month and they are so bad about customer service I disputed the charge on my card. I am still making the pig tails as I did in my other thread about this.

I also bought my board from AliExpress.

1 Like

This has been driving me nuts. My x and z endstops have all been intermittent but no problems with the y endstops. I knew it wasn’t my wiring because a simple power cycle often fixed it, then a while later it would start up again.

At least there’s an easy fix. I have a spare board though. I’m gonna throw it in there and see if that one has the same issue.

I installed the spare board and it had endstop problems as well. Rather than do any real diagnostics, I was in a rush and just blindly installed 1k5 resistors on all the endstops on the original board and threw it back in the lowrider. Well that seems to have fixed the X and Z endstops and probe but now the Y endstops have intermittent problems. So I’ll just remove those 2 resistors later this week and everything should be fine.

Weird I just have a problem on 4 of the six. Everyone else seems to have an issue with all or none. This board was purchased from big tree tech on amazon. The other one I have was purchased from biqu but I haven’t done any troubleshooting on that one yet so it could end up being a different issue.

I have an issue with 2 of 6… maybe 3. it’s odd bc if I run a long job sometimes one without a resistor stops working until power cycle. some day I will put resistors on all.

I’ve one idea why this “bug” doesn’t occur at the manufacturer:

1.) In my case only the stepper motor with the highest force was affected (Z motor if the milling machine was on the stepper motor side)
2.) It did not occur on the other Z side, only on one Z side
3.) What is so special about the “problem” Z side? It is connected via the “cable extensions” to the board.

Possible conclusion:
Maybe the board detects a “floating state” of the one Z end stop because the “cable extension” is changing the resistance of the connection? And in combination with the high force that the stepper motor have to do it is enough to generate a “floating state”.

@bms231 @_rob @FranderSays did you have the end stop problems only on end stops that were connected via “cable extensions”?