Loaded new firmware, now steppers will only move a tiny bit

Yeah, changed to new firmware, same repetier host, had worked fine for months, flashed the new firmware, now it won’t move freely, only in one direction, all the coordinates are red, getting some endstop message on the lcd, all the xyz flashing. Can anyone tell me what to do here? I have a ton of stuff to cut =)

I flashed the Marlin one, not the one listed above it, btw. I wasnt sure which I should use, i downloaded the other one too, but didn’t flash it yet. It was much larger.

Need to provide a lot more information to help.

What board, where did you get it, what is plugged in, what did you flash. Pics would help as well.

If it was all from here, nothing has changed so that would indicate a bad flash, if it’s elsewhere could be anything. Details will help.

Bought it all online. Same LCD you use, arduino mega at 2560, polulu stepper drivers, NEMA steppers, it all worked flawlessly on the first firmware you posted, for about 6 months now. It stopped working a few nights ago, tested the power supply, and had a bad connection. low volts. So I fixed it and it worked. Then I went online saw the new firmware, and loaded it. Now it just acts confused when I try to manually control, gives me an endstop limit message. I don’t have endstops. I used to set it maunally to zero, then zero the host and cut. Now I can’t move it freely, just til it hits a wall in one direction.

Do you have endstops plugged in?

Did you flash the correct firmware? You didn’t really answer what you flashed? What exact file. Ramps? Leadscrew or 5/26"? You really need to give more information if you did not get it from me I have zero knowledge of what you have, makes it hard to help.

Sounds to me like you either flashed the wrong firmware or you have endstops.

I just didn’t know if it was a ‘hey just uncomment ‘x’ and you’re good to go’ or whatever. Like a difference in default settings. It seems to think I have endstops and that wherever it is when it starts is zero, and I can’t travel negative. Oh, I still have the resistor on T0, did we need to remove that now?

The power supply issue could have also killed your board?

Sorry, no endstops, using 5/16 screw. I loaded marlin 1.1.3 , I was GOING to load MPCNC511_GLCD , but I saw the marlin. Couldn’t tell which I was supposed to load.

what is marlin 1.1.3?

This is the only pre configured firmware, you can’t just load marlin from github.

No, a piece of wood fell on the wire and pulled it from the terminal, It never ran with low current. I tried to use it, nothing would move, so i shut it down and found the issue in a minute or two. Then it worked again. The issue only started when I chnaged the firmware

Yeah, I just followed the link, and did the marlin 1.1.3 download, not realizing. Durr. I felt like it was on the same page. Do I need to make the lcd edit on the MPCNC511_GLCD firmware?

What edit?

uncommenting the proper LCD, but duh, it;s the one you use, soooo… sorry I’m ‘that guy’ today. You’re too busy for this, but you helped me anyway, lol. I’m still learning about ALL of this, and you make it easier every day, with your work here. GREAT machine, really.

It was uploading as I posted. Runs like a champ again. Thanks, guess all I needed was the right firmware, but went and overthought it.


It is no problem, I/we are here to help. We all make mistakes. Just glad your sorted out and running that easily.

Yeah, just had one last issue. Is the default ‘y’ direction opposite now? I tried to do a cut, but the y was inverted. So I changed it in repetier, restarted it, reloaded the .nc file, and retried, but it did the same thing, regardless of whether it was inverted on the settings or not. Do I need to set estlcam to invert those from now on, or cna I change it in the firmware?

Just power off, unplug the power, then flip the y axis plug over.