LCD is blank and board doesn't connect

Hi folks, i just finished building my MPCNC, when i connected everything only one of the motors from X and Y was moving and the LCD was flashing ? on the X Y Z. Now the lCD has gone blank and it wont connect to the computer. Please help @vicious1


Sounds like you had series firmware on the board.

Please verify your power supply is functional. Best to unplug the 12V lines while you do, but check the 12V ports for 11.9v-12.5v. On the power supplies you have make sure you are on the right voltage for your country as well.

Power supply showing 12v on the dot. I verified all connections.

That just leaves one or both of the two very small gold fuses on the Rambo board.

Before you replace them, you should take a hard look around to see how they popped. Typically, that only ever happens from plugging in the power supply reverse polarity.

Also you should double check the plug position of the get those wrong and you can send power to signal or ground. Each side is opposite so please double check.

Negative and signal is what you want, no positive pins.

So the board was working just fine, I turned it off because of the motors was going the wrong way so I flipped the wires and after that I turned it on, that was the last time. Today was the first time I connected the board since I purchased it.

Which plug positions?

1 Like

LCD was flashing ? on the X Y Z

Addressing one tiny part of your problems, the β€˜?’ on the display is normal. The display will alternate between β€˜?’ and a coordinate when Marlin does not consider itself homed. Once you’d home your axes, the β€˜?’ would go away, though if you use your machine like most people, when you execute a G92 to set the origin relative to the stock, the β€˜?’ on the display will return.

Endstops. I’m pretty sure he meant to say endstops.

Unplug the endstops for now. Until we get it moving again.

Were you able to check the fuses?

1 Like

yup, my bad.

OK New Problem guys, just tried to upload the new firmware using xloader, the upload went fine but now the board is displaying a solid red light and the screen is just blank now. I tried it twice, the data seems to be flowing as the firmware is being uploaded but once finished the solid red light appears.

Why was your board not powering on? If you keep us informed, we can help much easier.

1 Like

The end stop was causing not to power on, I disconnected the end stop and it powered on just fine, I moved on to upload the new firmware using xloader and once loaded, it restarted the board which then it gave me the red light on the board.

Which firmware did you load?


Can you connect to it with repetier host?

So i connected to a different computer and the firmware uploaded correctly and now it’s working. Now comes the fun part of squaring and doing some test runs.

Thank you all for the quick response and support.

1 Like