Laser - Ramps - ARGH!!!!

Okay. I have been wanting a laser for a while so I broke down and bought an E-bay special to “get my feet wet”. I have the laser, designed and printed a mount for it, and need to update the firmware to run pin 44 for the TTL thingy. Downloaded the newest firmware…made the change (I think…more in a second on that), and tried to upload to a spare Mega 2560. Insert gong show “bong” here.

Okay…changing pin 9 (fan) to pin 44. Going through the MPCNC-laser-add-on-walk-through.pdf section b has changed.(?) I made the change in pins_RAMPS.h as follows:

#ifndef RAMPS_D9_PIN
#define RAMPS_D9_PIN 44 // changed to 44 from 9

I don’t know if that was the correct move or not…please someone correct me if I am wrong.

After changing I tried to upload. I get an error (see attached file). I have tried the old u8glib and the new u8glib (I recall having to use the old one when I previously flashed the Mega back in December). Didn’t help. I’m stuck…and frustrated.



aa-marlin-error-180905.txt (550 KB)

You are trying to use arduino 1.8.5. You have to use 1.9 or higher. Details on the firmware page.

Bet you had a nickle for every time you had to say that. Thanks. I’ll buy you a bear at the MRRF next year. Was I correct with changing the code in thepins_RAMPS.h?


The previous post just before this reply was the exact same…so we are at $0.10…can’t wait. I will bring a cooler.