Kelly the Carver's Portable LR3 Build Thread - Ice Edition

No they aren’t. I have several others. I’ll swap them with a matched set from my Burly. The one in question is from the Z axis of the Burly but I’ll swap it out so it’s out of play.

1 Like

Two matched steppers. X on the left, C on the right.

Stepper test 1

Stepper test 2

@vicious1 So Ryan, when you said you set it up at your place everything was fine? Like they both moved at the same rate? Just confirming.

1 Like

Heres the same config on mine:

Maybe your steppers are not both 200 steps per revolution?

3 Likes

With motors on the bench, try swapping X/C. That will rule out (or confirm) steps per revolution on motors.

I know you did basically the same thing with the cores but there may have been multiple things interacting and confusing things.

1 Like

Okay, am I insane? Does this not look like things are perfectly in step? I made ZERO changes…was going to record this, swap the plugs and record again…

Stepper Test 3 - I really should look into how to embed YouTube videos in the forum…

1 Like

Thanks for the sanity check!

Exactly how should I answer that one… :joy:

1 Like

Well, can I give this one for old time’s sake to Dui @forcerouge ?

I was certain the first two tests were differing speeds and then the third test with NO changes made other than powering up and trying again it was was like “What? What’s wrong? There’s nothing wrong here.” So much so that I had to come out and test again. And it was locked in. Simulataneous, in sync.

Ah! But there WAS a change. Should I leave it there and let you all see what’s different? The clue is in the Dui reference and a blast from the way way way back machine.

Very, VERY oddly I rolled my way through my MP3DP build thread last night for some reason - I have no idea why on earth I did but I did. Anyhow - when I was building my MP3DP I was having all sorts of troubles and you all were rallied around me just like now trying to help me through it. There was one particular problem with skips or low extrusion - I can’t exactly recall but in the end it turned out that there was a loose grub screw in the bowels of the extruder/hotend assembly. Somehow Dui sussed it out and it solved all kinds of WTFs.

So what changed from tests 1& 2 to test three?

I pulled off one of the pulleys. Why didn’t I pull off both? I couldn’t find an allen key to fit and just wanted to get the test run again.

But then how did I get the first pulley off you ask?

It just slid off. If you look at tests 1 & 2 you’ll see the pulley is resting at the bottom of the shaft. Tests 1 & 2 WERE in sync, but the pulley was loose. Loose enough to rock between one side of the flat spot and the other side. It literally just slid off when I went to take it off. So I looked harder at test 2 and grabbed some screen shots. Lucky for me I did a clockwise rotation first, then a counterclockwise. Had I only done one direction I may have not been able to spot it. Note where the grub screw is in relation to the flat spot on the shaft.

ShakeItToTheLeft

ShakeItToTheRight

If you play the first test at 25% you can actually see the stepper on the right start before the left but they ARE both starting at the same time, it’s just the deceleration on the left has slid that pulley around the shaft ever so slightly.

Now, remind me to point out that I was having accuracy issues with my Burly - where these steppers came from…good grief! I wonder how many other 'little things" were a bit messed up on that poor machine…I hope I treat my women better than I treat my CNCs…I’ll have to ask the wife. But then she’ll think I’m up to something.

So allow me to formally apologize for assing that up a bit here. I still maintain the cores were moving at differing speeds - I don’t think there’s any disputing that. But it appears not all steppers are created equal and matched sets are apparently pretty important. Thanks for the suggestion to try @Britt

I’ll get these installed tomorrow if I’m able - I have to carve my way through a lot of wood tomorrow so that the pieces are sealed up in time for early next week so not sure how much I’ll be allowed to play with the LR3. If not during the day hopefully tomorrow evening.

Thanks for strapping a second core to your machine too @jamiek - it looks SOOOOOO GOOOOOOD with two cores running in tandem doesn’t it? I can’t wait to get them cutting in unison. And thanks to everyone for sticking by me here - I’ll make sure to screw something up hooking up the probe or something so stay tuned.

4 Likes

Dun dun dun, another one bites the dust.

That is pretty nuts, the reason not of use suspected that is the numbers you had. A loose grub screw is 2-6mm differnce…smaller than it should be no matter the distance. You have 47mm larger, I think it was a combination of things, what a wild ride. I bet you will never have a loose grub screw again.

1 Like

:rofl: :rofl: :rofl:

A loose grub screw strikes again! I can’t count how many times someone in the forum has said my CNC isn’t moving the correct amount and someone else has said, “Check the grub screws!”
This time, nobody suggested it. Well I’m glad it’s all working and looking forward to seeing a video of it in action carving away at some ice blocks!

1 Like

Well sorta Britt, it was the mismatched steppers that were causing the “not moving enough” struggle. I sure hope we’ve solved that one. The loose grub screw was the “bench test killer”. Thank goodness that didn’t carry into the machine. Could you imagine if we’d determined that the stepper swap would fix things and I just tossed them in WITH that loose grub screw? Oh man. There’d have to be an award made up for that…

2 Likes

Well at least when I get my jackpot back I’ll know it’s been thorougjly tested :joy: :rofl: :joy: :rofl:

1 Like

OMG…I barely trust myself tinkering with my own stuff - your controllers have been a very safe distance away during all of this! Ha!

I have no words…I touched NOTHING. Left them plugged into the board to ensure nothing had changed from the worktop to the cores. Nothing at all…

I’m going to the sauna.

2 Likes

That has to be firmware related…I just don’t see how it can be good then bad.

1 Like

Two hours at 210 degrees was great therapy. I’m back at the work table and am going to do some tests and measurements, swap the plugs and do it again and then pull the cores off again. I’ll triple check the pulley teeth but feel like I have to be off by a good number for that to be the issue. In the sauna I was contemplating what if the belt just wasn’t meshed with the teeth of the pulley so I’ll see if I can suss anything in that regard but that’ll be answered if the fast core switches when I switch the plugs.

OK. Swapped plugs. Fast core remained the same - it was the secondary core. I’ll pull the steppers and do some more bench test (and check the pulley teeth).

Super bizarre.

Besides swapping them, you can also try plugging into Y1 and Y2 and jogging in Y, see if the behavior is the same.

Also feel them and see if they feel like the same strength or if one is weaker and skips steps more easily. I was trying to think if broken/crossed motor wires could somehow produce the behavior and I don’t think it’s possible but if there were some strange short circuit then the strength would be way off.

Also make sure to disable stepper drivers when plugging/unplugging. The old habits of disabling with M84 don’t work so probably best to power down each time.

The ratio of 145% is a strange number. If one motor has 200 steps per revolution the other would need to have 138, which is pretty much unheard of. Pulleys of 20 and 14 teeth would produce 145% ratio but that’s not really possible and it would be obvious.

My least implausible theory is one of the drivers is misbehaving, either it got partly cooked from plugging/unplugging while powered, or maybe there is a weak power supply from the board like if the conformal coating got somewhere and it’s making poor contact somewhere. When you swapped TMC drivers last time I think the UART was still wrong, so it could confound those results. And you swapped ESP32 devices without swapping the main board I think, so swapping the board is maybe on the table too.

1 Like

Nevermind, my least implausible theory is now impossible.

You don’t wanna know what I’ve just found…unfreakingbelieveable. And It has me wondering if it’s been this way all along? I’ll snap some pics, rectify what I’ve found and then fess up if it fixes everything. And try to explain how I missed it.

I’ll fess up either way. So flipping stupid…I should stick to chainsaws.

3 Likes

Spill the beans! 🫛