Judder on testprint


Just recently i have build my MPCNC.
I was amazed at how well the build went.
All parts fit together very nicely.

But now for my problem(s):

When i run the testprint, the vicious logo, i get a pretty horrible judder on the round portions of the print. I tested this print with a marker attached and the judder is very noticible.

Anyone else had this issue?

Problem 2. When i generate code from estlcam, the movement of the mpcnc is so slow, i would need a timelapse camera to see it actually moving. When i set the feedrate of the 3mm endmill to 200mm/s it actually starts doing something. I have the same problem from repetier and pronterface…

I could really use some tips!
Thanks in advance!



These things should all be included in your post. It makes it much faster to diagnose problems.

  1. Did you buy everything from here?
    a)If you didn’t or changed some things please don’t leave out any details.
    b)What firmware?

  2. Are you using end stops?
    a)If so please disconnect them.

  3. Are you using all my recommended parts?
    a) If not please list what parts you used.

  4. Include a picture so obvious errors might be spotted.

Thanks for your quick reply.

I am using all the hardware that is recommended. I did not buy it at your site.
Here we go:
Ramps 1.4, arduino mega combo
Nema 17 steppers.
The recommended drivers
Case with two fans for cooling the drivers
Wiring of steppers done in parallel
Gt2 16t pulles and gt2 belts
Build volume, 900x600x200mm

Im using the advised firmware from your site for the 8mm Treaded rod.

I have build the machine with the updated parts, 25mm conduit (stainless)

I am not using endstops. I didnt change the firmware.

I cant take a picture right now, but will do this very soon.

The testfile runs at speed, other prints do not.

One extra question tho, is it normal that the z-stepper gets pretty hot? The other steppers run very cool.

Try the newer beta firmware and correct the z steps to match your axis.

What amperage is recommended for your steppers , what voltage did you set your drivers to (drv8825?)?

I did like you suggested and flashed the RC7 firmware.
I also printed the heavy duty feet from thingiverse (http://www.thingiverse.com/thing:1459025).
Maybee i will also be adding the more rigid cornerblocks.
The more rigid feet help to counteract the judder. I think the whole setup was just too loose.

I also found that estlcam was not setup correctly. This caused the slow movement. When changing the settings i mistakenly set the feedrate (in the output options) to mm/s, while you clearly state it should be in mm/min. After i corrected this, the speed seems to be correct.

The fix for the hot Z-stepper was that the amperage was just to high. Fixed that aswell.

Thanks for the help :slight_smile:


I attached a video of the judder which is still there.
Edit: File is to big.

I disconnected the X and Y separatly. This does not help…

Anyone any ideas?

The chatter from the cutter?

Your movements are all very out of whack maybe post your settings here.

You are cutting aluminum with a very long z axis, your rapids and cut speeds look super fast and your travel moves are very slow.

Have a look at my aluminum video and get you r setting a little closer to mine. But you are going to always have issues with your z axis hanging out that far on aluminum. Most machines are built with only a 3" z axis looks like you are hanging out 5or 6 inches at least.

You also should test all your cuts on wood. If they do not work there it will not get any better in metal.

Yes i know i am milling with a to long Z-axis. But, i have this on all “faster moves”. I can only cut very very slow before the judder problem starts to kick in.
When i testprint your logo, this also happens… every corner has ripples in it.
It also happens with no tool connected to the machine at all, only the middle assembly…

It looks like the problem occures when the CNC is braking/slowing down…

You only showed it cutting so that’s What I saw wrong with that video. Trouble shooting in aluminum is kinda pointless, Things need to be close to perfect to make it work.

With a long zaxis you can have ringing from acceleration and deceleration at too high of speeds. You say slow but please give a number, slow is subjective.

I honestly think the biggest problem is going to be your z axis length and the speeds you are moving at right now.

slow is 5mm sec. I can do these speeds without the shaking problem.

I attached some pictures of the testprint.
The backing is MDF, so no grain or something underneath.

Dont get me wrong, i love your machine! Just want it to stop shaking :wink:

You are not really giving much to go on. The last pics are ball point pen drawn on particle board. The shaky lines could just be the surface under the paper, loose pen, or rough rials, all of which are made worse by a really long z axis.

Think of it this way, Tape a tool on the end of a broom handle and try to draw/cut with it. Then move your hand half way to the tool and try again, accuracy should improve by about double, keep doing this until you get the results you want, Most of us use a pen with our fingers very close to the tip, same for any cnc machine.

Im very thankfull for your quick responses. I can assure you, the backing is smooth and the pen was well attached. I used a pen so the wobble would show more. When using a marker they arent as good to see. Also, im using stainless rails. They are not rough or dirty.

Like i said earlyer, even when i completely remove the z-axis, the whobble is still there.

Im thinking more in the direction of a control problem?

I have never seen a stepper fail in that way. So either loose pulleys, or incorrect/uneven belt tension, bearings tension set to high on the rails, weak steppers, something rubbing.

A video of it happening, maybe a showing the rollers not moving smoothly. Your spec sheet for your steppers, and what voltage you set your drivers to, what software are you using to generate your gcode, or upload your gcode, step rate? Do all axis move the correct distance to at last .1mm? I have asked some of these questions before.

You just keep giving bits of info and rejecting my possible solutions. Give as much detail as you can.

Have you tried my test gcode, Does it work smoothly? Tried my torture test, does your machine handle it without skipping steps?