I am using the same code as the instructions.

sorry probe goes on, limit switches go off.

I have been considering changing out the ESP32 because some of the hang ups seem like the processor is freezing. But not sure if any off the shelf will work.

What code there are three sets of Probe code.

What firmware version are you using? $ss in the terminal will give us more info.

I am trying to step through this one issue at a time. Trying to trouble shoot a lot of issues at once can get really hard to do.

Can you solder? I have an idea.

I just realized you have a very early Blue Board, we can make it more stable with an added resistor.

1 Like

I bought it in December. Yes I can solder.

We ended up adding a 4.7k resistor from the 3.3V pin to the boot 0 pin. You can do it on the ESP32 or the bottom of the Jackpot board.

Some ESP were unstable, oddly enough the genuine ones were the worst.

If you want to grab some resistors I will reimburse you, I am sure you can get them from Amazon/faster cheaper than I can ship you one.

Do you have a picture?

Here’s a picture. Please excuse the sawdust.

The first two batches of boards went out before we noticed the funky booting. It only happens on some ESP’s. I assumed it was the cheap esp’s but it turns out most of them worked fine. When I got some genuine’s none of them booted at all. That pull up resistor takes care of all that.

I did test all the boards before they left and any then I sent out seemed to boot fine and I kept all the ESP’s that did not boot right.

Sorry that somehow that slipped through. If you have any issues with the fix I will swap you boards, but if you can solder that is a pretty easy fix. If you prefer to swap for one with the resistor built in we can do that as well.

1 Like

I will solder the resistor, all good. Hopefully this solves some of the other issues I see.

I’ll update you with anything on this forum.


Risstor installed I will try and do testing.

1 Like

A re-flash and wipe is probably a good idea with the latest fluid version from the docs. I am confident this will work, if not we can swap it out.

1 Like

I have been using for a bit and still running into issues.

Id say tool changes are my biggest problem.

I am still having connection issues after the first tool. I am unable to connect, most of the time i am having to write separate programs for each tool and hope it says in the same position after it reboots.

sometimes when jogging i loose connect and have to reboot.

Catch us up to where you are at.
What firmware version?
AP or STA Mode?

This is the most concerning. Are you sure your power is good and all your wires are secured in the board and to the machine as well to keep them from moving?

It absolutely not stay in the same position, you can add a home to each job section to be certain.

This is really not a common issues that I have heard. I am interested in your connection. Might need to try ap vs sta for you. With the added resistor, you have the most current board, is you add it to the jackpot itself
(instead of the esp)on the bottom, we can swap out your ESP for a genuine. It is either your WIFI situation or the ESP at this point.

I had some similar behavior (I think.) I’d be interested in any observations you have about the behavior.

When my machine was losing connection, I actually discovered that the board was resetting. Sometimes it would fail to load my config, and it would load a default that had homing disabled. I could do a software reset and the board would load the appropriate config and I’d be ready to run the next job.

It would occasionally exhibit this reset/connection loss even on a long Y-homing run. I park it against the wall, so the Y-home is a linear move of about 1800 mm. It would stop and lose connection about 60% of the way. After the reset, I could run a normal home (although about half of the time the config needed to be reloaded.)

All that said, it turned out to be some mis-assigned pins in my config files (I run one config for router, one for laser, and one for laser-rotary.(plenty of chance for error.)) It was also worse when I changed the polling rate.

If you successfully wipe and reflash, I’d suggest running a default config from Ryan’s repo to see if it exhibits the behavior.

Do you have anything non-stock attached? Hope this helps. I know how frustrating it can be. :grinning:

Using AP

Might as well update to 3.7.16.

Stick with AP mode for now and see if that helps. If not STA mode might work better for your situation.

I am wonder is it normal to loose wifi connection during movement? It seems to be the disconnect/connecting causing the issue. I turn off my wifi on my computer while it’s running and I am able to reconnect when it’s back at home.

The machine runs directly from the SD card, the wifi is only for manually sending commands. If the wifi connection goes out nothing should happen. Also there is a setting for the WIFI to not answer while the machine is busy, you can turn that off, that is to prevent ither issue from happening.

Make sure not to try an connect more than one device at a time or you can overwhelm the firmware. V3 prevents this from happening.