It's Been A While, I'm Lost

Been a while since I used the Burly, apparently long enough to harden the brain cells. Opened a file I’ve used before in EstlCAM, set all the parameters to my liking and wanted to do an ‘air’ run. Saved the CNC file to memory card and inserted card into the slot on the LCD screen. Turned on the machine, hit the Print From Media line and instead of seeing my program name as expected I get a line saying 'Main" with an upward pointing arrow, selecting this line returns me to the previous screen. I’d appreciate help getting me outta the woods as I can’t seem to find the breadcrumb trail.

Is it the only thing on the sdcard? It is probably named with .nc and need to be .gcode.

I must be brain dead this AM. It is the only thing on the card but I’m unsure of how to check the file extension, when I look at the card content, under ‘type’ it simply says CNC Programm(sic). It only shows as 49KB which seems kinda small? AFAIK I saved it the way I always did and I never had any problems with the set-up.

EDIT: Maybe irrelevant but I just had one of those MS (Windows10) updates whether I wanted it or not. Possible some setting changed?

EDIT: When I open the file on the SD card in EstlCAM it is Gcode.

I’m windows explorer there is a setting to show the file extensions. Forget exactly where, maybe under the View tab. That would let you know if it’s the extension causing the problem.

Edit: Directions

1 Like

Aha! Progress! Thank You!

The extension is .nc. I know I never changed anything from the last time I used it so now I need to know how to find what setting changed and how to correct it?

1 Like

You can change the extension type in estlcam. Or you can just rename it.


I just checked the CNC program setting in EstlCAM and ‘default’ is chosen. Shouldn’t that be EstlCAM? Or is there some other setting I need to change or is it as simple as manually changing the extension after the file? I have the feeling the latest (New & Improved) update was neither because I’d changed nothing and the first time I booted my laptop after the update I had no cursor and had to reboot and it then apparently installed the update…

OK, I see in the EstlCAM CNC program settings the file extension is nc, do I just change that to gcode with no dot in front? Should I also change the ‘default’ selection to EstlCAM or should it be Marlin?

I think so? I’m very far away from my computer at the moment.

1 Like

Thanks, I’m trying to locate the initial EstlCAM set-up instructions as I’d like to be sure nothing else mystically changed with no input from me.

1 Like

@barry99705, we can handle the extension questions this weekend. Please continue to post pictures of interesting things at MRRF. We are depending on you.


Thanks for this, I’d already changed the controller setting to Marlin and gcode and never a dull moment, I put the new file on the SD card it said no media, I inserted the card and it said media inserted, and when I tried print from media it said no media. It being 5 O’Clock somewhere it’s getting closer and closer to Margarita time. :roll_eyes:

Reformatted the card and Success! At least on an ‘air’ run.

It actually worked as I remembered after correcting the settings which AFAIK must have been changed during a recent update, I know for sure I did nothing to change the basic settings and it makes me nuts when something else does.

Thanks to all for your help! Still the most helpful forum I’ve ever been on!

1 Like

Man, your topic gave me an earworm: Staind - It's Been Awhile (Official Video) - YouTube. :smiley:

Kinda gave me a headache for a bit, I was doing what I thought I’d always done with no result and I knew I hadn’t changed any settings. I can only guess it was another fine ‘New & Improved’ update from MS. :roll_eyes:

1 Like