Issues with running Crown from ESTLCAM. No issues when using Ryans G code in Rep

So I was able to pull off the crown test with a pen by copying the G code for the crown thats posted here. However running the DXF into ESTCAM and using the engraving option per the instructions doesnt work and I get some kind of nonsense on Reptier in the print preview screen. Its almost like its making hugeeeeeeee toolpaths on top of something else. Im sure im making some kind of rookie mistake and I was hoping maybe one of you guys can help me out…

I took a ton of screen shots and also my settings maybe im missing something? My work area is 24"X36" btw. Im using a Rambo 1.4 with end stops.



Sorry my attachments didnt work

Check the units you’re importing with. Make sure the scale is appropriate.

Delete this mods

Its showing as MM for import settings.

Apparently the board doesn’t like having 8 images uploaded at once and errors out. Ill use Imgur for now.




Squiggly lines everywhere!!!


[attachment file=“test crown.gcode”]

This is the code ESTLCAM output after selecting the crown and using engrave

test-crown.gcode (21.6 KB)

the output is tiny and your Z axis is going down to 12mm.

Make your gcode and use repetier host to visualize it.

Do you have another gcode previewer you can use to view that code with? There’s a chance that Repetier just isn’t handling the G02 arcs gracefully in the previews. And looking at the gcode, it’s a teeny, tiny crown. All the arc endpoints live within a 2mmX2mm area or so… Maybe import as inches? Alternately, see if there’s a way to prevent EstlCAM from using arcs. I think Marlin is still having issues with them at the moment.

Im a bit more famliar now with ESTLCAM and I made the workspace the size of a piece of paper so I can reference the resize of the DXF crown better. One thing that throws me off is there is no type of measurement increase on ESTLCAM only “resize scale factor”.

After using the engrave option I saved it and ran it on a browser driven g code sim

[attachment file=“nc preview.jpg”]


Then this is what it looks like in Repetier the lines do in fact look different than ryans code but its getting better…

Mine with filament enabled:

[attachment file=“rep preview.jpg”]


This is ryans with filament disabled:

[attachment file=“ryan rep.jpg”]

The code I got from ESTCAM with 2 mm drop[attachment file=“0102”]


I wont be able to test it till tonight and maybe im putting too much faith into the Repetier previewer lol. But using ryans crown test worked and I would def feel better running something that looked better like his. (66.6 KB)

I just finished building my LR2 (aside from the router I don’t have yet); I have, maybe, the same issue.

When I use EstlCam - RepetierH to try to ‘engrave’ the crown, I have to pull the plug to keep the machine from moving off the bed - before it’s drawn anything recognizable. But, if I download Ryan’s crown gcode example it works great . I tried cnc.js as well as RH with no luck.

I re-flashed the firmware on my board and uninstalled/reinstalled EstlCam, thinking I had messed settings up somewhere - but it didn’t help. I tried several times to carefully follow the instructions on the EstlCam Basics page here on this site… no guarantee I didn’t mess up though.

I know that doesn’t help the conversation much yet, I’ll try using a visualization tool when I get home. If I have time maybe I’ll write up a more detailed list of steps so you can point out what I did wrong :slight_smile:

BTW -thanks Ryan for such an amazing machine!

[attachment file=118348]

So it’s working now and I will say this. Don’t put too much thought into the preview for repetier because at least on my pc it shows up kinda weird but seems to draw the same as ESTLCAM shows.

I’m pretty paranoid so I would love to see the preview work correctly but I did maybe like 5 successful drawings from Inkscape to Estlcam to Repetier.


So question for you guys…output code of my ESTLCAM vs Ryan’s Crown. Im pretty fuzzy with Gcode so bare with me. Ive been deleting my stuff and putting in Ryans stuff for now. Idk if im supposed to be doing that and if so is there a way to automate it?


Any estlcam I gcode I put out I get this…

G90 M03 S5000 G00 X0.0000 Y0.0000 Z0.0000 F2100 G00 Z2.0000 F480

Ryans has this which has the G92 and no machine codes:

G92 X0 Y0 Z0
G00 X0.0000 Y0.0000 Z0.0000 F2100
G00 X0.0000 Y0.0000 Z5.0000 F500

It looks like you’re finding the same thing I just did.

I compared the gcode that EstlCam generated with the gcode on Ryan’s “Test Crown 12mm/s” and found that the G92 made all the difference. I can just add that (G92) to my own generated gcode and the ‘pen’ doesn’t try to move somewhere crazy.

I haven’t had time to study EstlCam settings or post-processing (is that what’s needed?) yet, but I’m guessing there’s a better way than deleting and inserting gcode each time?

Busy Saturday ahead, but I’ll try to experiment and report back if I find anything helpful.

1 Like

If you end up figuring out how to add it to post processor let me know. It’s a combination of me being lazy and also possibly forgetting. If I have time tomorrow I’ll try messing with it myself.

Just put it in the Starting gcode tab.

There is a lot to take in but if you go between the crown and basics page most everything you need is in there. Tough to balance enough info to be useful and lite enough for people to actually read.

1 Like

That worked perfectly, thanks Ryan. I never thought to look under “Texts” (it took me a while to find).

I think it would be helpful to add one more setting in Step 2 of EstlCam Basics, right after setting the feed unit; letting poor noobs like me know that they might need to open the “Texts” tab and add G92 to the Program Start section if they don’t want their gantry wandering off the bed. Unless it’s just something specific to my setup of course.

Thanks again!