Installed mpcnc post processor

I got the post processor installed with no issues. I’m connecting to the skr 1.2 board via repetier host.
I have manual control. but when I load the file and hit start it gives me an eta but nothing happens.
I feel like I might be missing something. I got it run from a estlcam file, but all my design work is in fusion.
any help would be greatly appreciated.

I’m assuming you authored a project in Fusion 360, authored a setup and toolpath in Fusion 360, and then used the MPCNC post processor to generate a g-code file. Note I’m also assuming that you setup your postprocessor to generate files with the “.gcode” extension, not a “.nc” extension. If you did all of this, the most likely root of your problem is that you have a M0 in your g-code that is waiting for your input. You can take a look at the top of the g-code file, or you can post the first 40 lines or so to the forum, and we can take a look. As a debugging step, you can run the file from the SD slot on the TFT screen (not the control board) to eliminate Repetier-Host as the root of the issue.

I see a M0 command on line 53.
;Fusion 360 CAM 2.0.11405
; Posts processor: MPCNC.cps
; Gcode generated: Sunday, October 24, 2021 5:43:27 PM GMT
; Document: board template v2
; Setup: Setup5
;When using Fusion 360 for Personal Use, the feedrate of
;rapid moves is reduced to match the feedrate of cutting
;moves, which can increase machining time. Unrestricted rapid
;moves are available with a Fusion 360 Subscription.
; Ranges Table:
; X: Min=-2.159 Max=308.991 Size=311.15
; Y: Min=-2.159 Max=514.096 Size=516.255
; Z: Min=-14.224 Max=15.24 Size=29.464
; Tools Table:
; T1 D=6.35 CR=0 - ZMIN=-14.224 - flat end mill
; Feedrate and Scaling Properties:
; Feed: Travel speed X/Y = 2500
; Feed: Travel Speed Z = 300
; Feed: Enforce Feedrate = true
; Feed: Scale Feedrate = false
; Feed: Max XY Cut Speed = 900
; Feed: Max Z Cut Speed = 180
; Feed: Max Toolpath Speed = 1000
; G1->G0 Mapping Properties:
; Map: First G1 → G0 Rapid = false
; Map: G1s → G0 Rapids = false
; Map: SafeZ Mode = Retract : default = 15
; Map: Allow Rapid Z = false
; *** START begin ***
; Set Absolute Positioning
; Units = mm
; Disable stepper timeout
; Set current position to 0,0,0
M84 S0
G92 X0 Y0 Z0
; *** START end ***
; *** SECTION begin ***
; X Min: -2.159 - X Max: 308.991
; Y Min: -2.159 - Y Max: 514.096
; Z Min: -14.224 - Z Max: 15.24
; 2D Contour8 - Milling - Tool: 1 - flat end mill
; >>> Spindle Speed: Manual
M0 Turn ON 16000RPM
M117 2D Contour8

So the problem is that your system is paused waiting for your input. I run headless (i.e. off an SD Card) on a Rambo, so I’m not sure exactly how Repeteir-Hosat/M0/TFT/SKR Pro would/should work. You can remove the M0 using a text editor as long as the router is turned on before you start your file. You can also put your TFT in Marlin mode (hold down the knob for 10s), and then I know you will get the M0 prompt and can respond. I’m not home to test it, but I think turning off Manual Spindle in the postprocessor will eliminate the M0 prompt. Note I use Fusion 360 for all my MPCNC jobs, so it is just a matter of getting your recipe right to make this work.

Thanks, It works via usb on the tft
Now I guess I should finish building this thing.
I always like to bench test wired up.
my original plan was to mount the main board inside a garage computer.