InkScape to EslCAM

I see dozens of posts on this but I can’t seem to find a solution.

I have managed to create the image I want in Inkscape, and I save it in the .dxf format, but when I try to bring it into EslCAM I get an “Empty or Incompatible drawing” error. I tried the “Deep Ungroup” and “Object to Path” in Inkscape but nothing seems to happen. I also tried saving it as a .svg file (and many other things) with no success. I’m stuck!

Where do I go from here? Thanks for your help.

The way I do it in ink scape. Bit trace, single scan. Deleted original image, ungroup, then save as an optimized SVG. I could never get estlcam to recognize inkscapes native SVG or with the original image overlayed. but I also use it for images only

I’m not an inkscape expert, and I haven’t had trouble with estlcam and svgs. But did you import and bitmaps (jpgs, pngs, etc)? If that isn’t it, maybe post the SVG and someone who knows more can see what’s going on. (1.7 MB)
Maybe it’s the way I created it. I took an SVG file (which will load into EslCam) and combined it with a frame that I designed in CAD as a .dxf -R14 file (which will also load into EslCam). Anyway, I’m attaching the .svg file. If anyone can make it work, it would be greatly appreciated.

PS: I could not figure out how to upload the file. It would upload, but wouldn’t show up in the post. Thus the link to it.


1 Like

@flyntm No imagine was attached.

See my edit above. Let me know if that doesn’t work. And Thanks!

Thanks for everyone’s help! I just started over and did the whole design in Inkscape. After I did the “Deep Ungroup” and “Object to Path” in Inkscape, it loaded into EslCam as expected.

I took a look at your SVG. I started by following @diddledirt 's suggestion, and saving it as an Optimized SVG out of Inkscape. The results do load in EstlCAM, but it was not very usable. Paths were not connected, and it ran slowly. I pulled the SVG into LightBurn to see what was going on. When I zoom way in, what appear to be lines in your drawing are not. This is what I see is this:

The double pink lines at the bottom are what I expect when tracing lines in an image. The two paths of ovals are how your tracing solution converted your gray/black lines to an SVG. The result is an SVG with probably tens of thousands of objects and an unusable path with respect to EstlCAM. If you did this conversion in Inkscape, I’m sure you can find settings for tracing that mitigate or eliminate this issue.

So, I tossed all of the lines and focused on the tracing of the filled portion of your graphic. With just a few minutes of cleanup, the results work fine in EstlCAM. Here is the file (you can right click and save the SVG):


If you need the outline lines, re-drawing them in Inkscape would be my suggestion (rather than trying to trace them from the image).

Thanks, Robert. I did as you suggested and redrew the frame in Inkscape. This appears to have worked and loaded imported into EslCam correctly.
I find Inkscape to be a very cumbersome drawing tool. I’d like to find a way to combine a .svg or .jpg file with my CAD .dxf files into something that’s usable by Eslcam. But that’s for another time. I think what I have now will work for this project.

Thanks again to everybody that read and responded to my inquiry.

Lately I’ve been using Lightburn for these kinds of tasks. The tool is a one-time purchase, and is focused on laser work, but if I have complex vector tasks, it does the job.

  • Easy to size and align objects
  • Imports DXF and SVG
  • Handles large numbers of SVG objects exceedingly well.
  • Decent image tracing functionality
  • Simpler interface and ramp-up compared to other vector tools/

I too struggle with Inkscape. I’m sure if I spent the hours/days to become proficient, I would like it, but there are too many tools, and not enough time.

1 Like