Initial crown test results in jagged diagonal line

So, I got everything set up and wired properly. Tramming around with repetier works fine.

I’m guessing I screwed something up generating the paths with estlcam, but the “12mms Crown file” generate the same type of geographic hillside drawing. Not sure how to troubleshoot this.

I’m not using anything that isn’t in the build process (software wise). I am using the universal tool mounts, but am VERY doubtful those are causing this - this is really the only difference.

Windows 10 Pro; Repetier Host, estlcam software. Rambo (dual firmware version - not using the endstops [yet]). Sharpie marker.

Photo link (in case upload doesn’t work):

I’m hoping this is a common enough occurrence that someone will have dealt with it before.


EDIT: I tried to hit the reset button on the board prior to hitting print in repetier based on some threads in here, no dice. =(
EDIT: Tried G92 X0 Y0 Z0 - no dice. Also added a few more photos of the whole setup. Not sure what other photos to post.

If you don’t have end stops in place, you have to trick the board into thinking they’re there, otherwise it won’t do negative moves. Or, you could just flash the normal firmware for now, then put the dual firmware back on when you’re ready.

It looks like the steppers are wired incorrectly. Verify this by testing with Repetier.

Testing section.

Ohhhhh, wait I see what you are getting at Barry. If you are using the dual firmware and no endstops the machine will only move in the positive direction.

Oh, I see. That is quite funny… ok. I guess I have about the same amount of work ahead, either wire up the endstops or flash the firmware…

Can I simply plug in the endstops and not use them?

Also, is there a link I can get for the two firmwares so I can flash and then reflash if I decide to go that route?

Simply plug them in, and dont use them.

Do I need to plug the actual switches in to the board (completing a circuit, etc) or do I just need cable plugged into the switch slots on the board itself?

I think that depends if your firmware thinks they are normal open or normal closed. Its line 441 in the configuration .H file. Here is a link to the V1 information on endstops.I think if they are wired normal closed the motors will move any direction but be careful you dont run your motors to far over.

nvmd I found it.

ok, I wired up the switches and plugged them in (+, s) and then flipped the connector because the first way didn’t work. Both result in the same thing. Pics attached… did I miss something after plugging everything in (board was off while plugging everything in, naturally)?

Not + and S, - and S! when you close the switch you’ll blow things if you have + connected.

Ha. Oops.

huzzah! Its drawing a crown now! Thanks everyone!!!1111oneoneone

1 Like