Illegal User App

Hi All,
I broke my TFT firmware. I tried to rebuild the firmware and update my board. Build was successful (no changes) and I grabbed the file from “Copy to SD Card…” directory and used the Config.ini and TFT directory from the GitHub link. This seemed to work although I noticed after the update that the date on the file wasn’t today. Did some digging and found the new file in “.pio/build/BIGTREE_TFT35_E3_V3_0”. Tried the update again and no it get illegal user app on power up or reset. Tried coping the original files back on but it still does the same. Formatted the SD card and copied the bin, ini and TFT directory on alone. Same problem.


I tried a different card and that made no different. I went poking around the web about found someone with the same rev board as mine (TFT35-E3 v3.0.1) and was having the same trouble. The response from BigTreeTech was to use BIGTREE_GD_TFT35_V3.0_E3.27.x.bin not BIGTREE_TFT35_V3.0_E3.27.x.bin. That worked but why? Putting back BIGTREE_TFT35_V3.0_E3.27.x.bin causes the error (and the GD resolves it).

This page directs me to a GitHub SKR Pro - V1 Engineering Documentation which doesn’t have the GD version. I’ve been using the Lowrider for a few months. Where the heck did I get the firmware originally? I’m very confused.

Looking further I see others in the forums talking about the GD version. Can someone confirm I’m using the right file?

Thanks for your help!

There are two chips in these boards, at some point the GD version made some sort of compatibility split. I only order the non GD version, but it seems a few have slipped through. (the gd chip version is a hair better for some reason)
Technically the firmware you download from me does have the GD version as well it is just deeper in a folder.

I think the next release I will put both files in the folder and the board should only flash the correct file for it.

1 Like

Thanks Ryan! You were out of stock when I wanted to order the board so it didn’t come from you. Unfortunately, as soon as mine shipped, I got the “in stock” notice from you.

I was unable to find the GD version in the Lowrider3 docs or the firmware page which links from it. Perhaps a change during the new hosting. Anyway, all up and running. Thanks again.

Glad it’s working. In case anyone sees this before I update, the file is in " Copy to SD Card root directory to update /" folder there are a whole list of bin files for every screen Btt makes. A few have “GD” in the names