How To/Heated bed not working

How do you add a heated bed. I followed the instructions found in various posts but am unable to have it detected. Does the firmware provided account for the bed?
I have the heated bed with termistor from here, a 30A power supply connected on both rails.
I connected the power to D8 and the termistor to T1. Anything else?

You need to change line 232 in the firmware.

Some screen shots, and a changed firmware.

Here is an edited one for you,

Great, heating now. After a few minutes I get this error:
21:08:50.971 : Error:Heating failed, system stopped! Heater_ID: bed
21:08:50.974 : Error:Printer halted. kill() called!

At around 58C I read I should heat to 70C to get a good bond. Some place indicates 50-60C.

I need a screen shot of the errors, that isn’t really saying anything important.

Did not get to capture the screens before I started the autotune process per’s_guide and get a few errors:

`21:56:17.166 : Printer reset detected - initalizing
21:56:17.166 : start
21:56:17.170 : echo:Marlin 1.1.0-RC7
21:56:17.170 : echo: Last Updated: 2016-07-31 12:00 | Author: (none, default config)
21:56:17.170 : Compiled: Oct 17 2016
21:56:17.174 : echo: Free Memory: 3255 PlannerBufferBytes: 1232
21:56:17.179 : Error:EEPROM checksum mismatch
21:56:17.179 : echo:Hardcoded Default Settings Loaded
21:56:17.179 : echo:Steps per unit:
21:56:17.182 : echo: M92 X200.00 Y200.00 Z4535.44 E200.00
21:56:17.183 : echo:Maximum feedrates (mm/s):
21:56:17.187 : echo: M203 X190.00 Y190.00 Z8.50 E25.00
21:56:17.187 : echo:Maximum Acceleration (mm/s2):
21:56:17.187 : echo: M201 X500 Y500 Z35 E10000
21:56:17.191 : echo:Accelerations: P=printing, R=retract and T=travel
21:56:17.191 : echo: M204 P400.00 R3000.00 T500.00
21:56:17.199 : echo:Advanced variables: S=Min feedrate (mm/s), T=Min travel feedrate (mm/s), B=minimum segment time (ms), X=maximum XY jerk (mm/s), Z=maximum Z jerk (mm/s), E=maximum E jerk (mm/s)
21:56:17.203 : echo: M205 S0.00 T0.00 B20000 X4.00 Z0.40 E5.00
21:56:17.203 : echo:Home offset (mm)
21:56:17.203 : echo: M206 X0.00 Y0.00 Z0.00
21:56:17.208 : echo:Material heatup parameters:
21:56:17.208 : echo: M145 S0 H190 B50 F0
21:56:17.208 : echo: M145 S1 H240 B110 F0
21:56:17.208 : echo:PID settings:
21:56:17.212 : echo: M301 P17.98 I0.98 D83.62
21:56:17.212 : echo: M304 P10.00 I0.02 D305.40
21:56:17.212 : echo:Filament settings: Disabled
21:56:17.215 : echo: M200 D3.00
21:56:17.215 : echo: M200 D0
21:56:17.311 : N1 M11034
21:56:17.311 : N2 M115
21:56:17.311 : N4 M11435
21:56:17.330 : N5 M111 S6
21:56:17.331 : N6 T060
21:56:17.331 : N7 M20
21:56:17.331 : N8 M8019
21:56:22.918 : N11 M220 S100
21:56:22.921 : N12 M221 S10083
21:56:22.922 : X:0.00 Y:0.00 Z:0.00 E:0.00 Count X: 0 Y:0 Z:0
21:56:22.922 : N13 M111 S6
21:56:22.922 : echo:DEBUG:INFO,ERRORS
21:56:22.924 : N14 T015
21:56:22.926 : echo:Active Extruder: 0
21:56:22.926 : Begin file list
21:56:22.926 : End file list
21:56:22.930 : Error:No Line Number with checksum, Last Line: 11
21:56:22.930 : Error:Line Number is not Last Line Number+1, Last Line: 11
21:56:22.930 : Resend: 12
21:56:22.935 : Resend: N12 M221 S100
21:56:22.935 : Resend: N13 M111 S685
21:56:22.935 : Resend: N14 T0
21:56:23.017 : echo:DEBUG:INFO,ERRORS
21:56:23.017 : echo:Active Extruder: 0
21:56:50.235 : N24 M303 E-1 C8 S9077
21:56:50.239 : PID Autotune start
22:06:50.640 : PID Autotune failed! timeout
22:06:50.641 : N33 M104 T0 S205
22:06:50.643 : N34 M104 T0 S022
22:06:50.647 : Error:No Line Number with checksum, Last Line: 31
22:06:50.651 : Error:Line Number is not Last Line Number+1, Last Line: 31
22:06:50.651 : Resend: 32
22:06:50.656 : Resend: N33 M104 T0 S205
22:06:50.656 : Resend: N34 M104 T0 S0*22

You can’t really autotune the bed, we use bang bang on it not a PID.

Try without that just use it and see what happens.

Ok, tried that again as the autotune failed:

22:10:55.990 : N126 M140 S79*94
22:10:56.639 : N128 M140 S80*86
22:10:59.273 : N129 M104 T0 S204*45
22:11:00.199 : N131 M104 T0 S205*37
22:12:57.031 : Error:Heating failed, system stopped! Heater_ID: bed
22:12:57.031 : Error:Printer halted. kill() called!
22:14:03.274 : Communication timeout - reset send buffer block
22:15:07.588 : Communication timeout - reset send buffer block
22:16:11.899 : Communication timeout - reset send buffer block
22:17:16.216 : Communication timeout - reset send buffer block
22:18:20.528 : Communication timeout - reset send buffer block
22:19:24.839 : Communication timeout - reset send buffer block
22:20:29.154 : Communication timeout - reset send buffer block
22:21:33.465 : Communication timeout - reset send buffer block
22:22:37.778 : Communication timeout - reset send buffer block

Can you send a whole screen shot of a failure that doesn’t seem to tell me anything. it is commands and then an error, as if it just got unplugged.

It say set bed to 79, set bed to 80
set hot end to 204, set hotend to 205 (not sure what the star with the number means)

Then says failed.

What happened, how long until you got that error, did anything get warm? a full screen shot tells a much larger picture.

Looks to me like it turns the bed on, waits two minutes then fails because the bed hasn’t warmed up. Any chance a sensor is disconnected so it’s always showing cold? Or perhaps the bed really isn’t warming up…

And in perusing the source it looks like the ‘*’ designates the start of a checksum for the command.

You are getting not heat to the bed at all? What port is is plugged into Should be D8? d8 is bed, d9 print fan, d10 extruder.

Yes, bed is connected to D8 and warms up and shows temp increase on the sensor. It goes up to around 58,6C and crashes, only if the extruder heats up as well.

Any news on this or are you still stuck? I might have time to plug in a heated bed this evening if you are still stuck.

Still stuck. Tried again today to just head the bed to 70C.

17:56:42.247 : Starting object analyser …
17:56:42.257 : Object is manifold.
17:56:42.263 : Analysing finished.
17:58:11.946 : N168 M140 S70*93
18:06:13.506 : Error:Heating failed, system stopped! Heater_ID: bed
18:06:13.509 : Error:Printer halted. kill() called!

Works fine on this end. Flashed the firmware I uploaded for you. Heated the bed. Attached a screen shot, I went to 40 and realized you wanted 70 (pretty hot, normally use 45 for pla). Lets see your temp graph, mine is set at 10min.

Are you sure you have a 30A power supply attached? If it isn’t at least 20A it won’t heat up and will fail for taking too long.

Attempt to reach 65C. Used a heat gun this time to help accelerate the heating. After reaching 60 I stopped. The temp actually dropped right afterwards. Increased it to 70C to help boost the heat, no luck, keeps dropping and eventually crashes.

How big is your heated bed?

are the wires soldered on the 12v pads or the 24v?

The bed is from your site, about 22x22cm. Wiring was already attached (I believe for 12V) and is connected to the D8 port on the Ramps. I noticed it heats up rather slowly compared to yours. Might trigger a failure to heat due to speed.


Here the setup.