Homeing Issues

Ok so this is hard to explain but I have to set the offset on the LCD then hit home just so I can move the axis. I added some videos so I can show what it is doing better. I’m using the parts kit from here and the large LCD. The software is what is listed and all is correct according to the setup page then I added the support for the LCD and got it working but the SD card does not even see it, and it works fine on my 3d printer which is the same set up. I also tried a different card and same result.

LCD only
With Software
SD Card not working

This things should all be included in your post. It makes it much faster to diagnose problems.

  1. Did you buy everything from here?
    a)If you didn’t or changed some things please don’t leave out any details.
    b)What firmware?

  2. Are you using end stops?
    a)If so please disconnect them.
    b) If the problem is still there leave them disconnected while troubleshooting.

  3. Are you using all my recommended parts?
    a) If not please list what parts you used.
    b) I am not against other peoples parts but most of them have not actually even been tested on a working machine. I am against people making “improved” parts when they have not even tried mine. Please, “don’t fix what ain’t broke”.

  4. Include a picture so obvious errors might be spotted.

Did you follow,


So many things, If you answer those first questions this would be easier. Sounds like your drivers are up too high or your wiring is wrong.

The homing thing is because your end stops are wired wrong.

What size is you sd card and what format is it? These work best with 2 gig or under and have to be fat32 as far as I know, you probably have it ntfs if it is large.

Ok here is the answers to some of your questions.

  1. Did you buy everything from here? Yes all of the hardware and electronics
    a)If you didn’t or changed some things please don’t leave out any details. I added support for the Full Graphic Smart Controller.(I have also tried without this.)
    b)What firmware? Marlin 1.1.0-RC3
  2. Are you using end stops? No
  3. Are you using all my recommended parts? Yes

I have tried to run this with the drivers turned down same result it does work when i go through," Set home offsets>Auto Home" i have drawled with it. and that seams to work.
I am using a SanDisk 2gb Fat32 SD Card have used it for years with my other 3d printer.
And i do not plan to use this machine for 3d Printing.

Please use my firmware at least for trouble shooting. The beta even has the lcd edits.

The drivers should be set to .7v for the x and y and .45v for the z. These are extremely sensitive you absolutely need to use a meter for this.