Help with LR3 Jackpot Setup


I have just built my LR3 and it moves freely in all directions. I have received my Jackpot board from V1 and installed and wired it up. I’m now stuck as to how to get it moving. The motors don’t seem to move in the correct sockets based on the wiring photo on the website. Also, my steppers just make a loud grinding noise and the thing seems like it’s jamming up. I can it it to move a bit but then I get an alarm on the software about not finding a switch. The switches all work and turn the lights on and off but it’s getting nowhere near the end and hitting them. It just moves a bit then back the other way a bit.

I feel like I have missed a step where I need to initially set up the board and lengths of travel or something but can’t find anything that shows this. CNC is completely new to me and I don’t understand a lot of what’s on the wiki.

Is there an idiot’s guide somewhere that goes from plugging in the steppers and powering up to making it actually move?

I enjoyed the build but now feel completely out of my depth.

Hello Mike and welcome!

Couple of questions…

Did you buy your stepper motors from V1 or somewhere else?

Are the lights for your endstop switches on or off when they are NOT pressed?

Also can you throw up a pic of how you have the board wired?

1 Like

We’ll help you along- my bet is the endstops arent wired or connected quite right. Your pictures will help us help you.

I bought the steppers from somewhere else.

I have just been testing them after removing 1 at a time from the machine and 2 are definitely bad. I’ve ordered replacements and will fit those which will hopefully make it work properly.

The lights on the switches are on when they are not pressed.


Thanks, the endstops seem to work properly when I test them manually. Hopefully its all down to the bad steppers. I’ll swap those and fingers crossed it will work.

1 Like

That’s pretty rare- pictures will help.

Just a note- never plug or unplug anything to the board while it is on.

JJ’s question about the LEDs is important- are The LEDs on or off for you when they are not triggered?

The motors most likely have a different wiring order than the driver on the Jackpot. My rotary motor is different and I have to use one of the wiring adapters that came with it. @MakerJim helped me figure that out.

It moves, turns out it was those stepper motors. It all moves as it should using the jog command, now I’ll look into getting it all squared up and do some test cuts.

Did you have to flip the middle 2 wires?

So I have now had 2 more stepper motors just suddenly stop working. They are fine one minute then just start making a load grinding noise while the end just sort of vibrates instead of turning. So far all the ones that have failed have been my old ones I bought a couple of years ago but I have 5 new ones and don’t want the same to happen to them if there is something wrong.

It’s all wired correctly and worked fine for a while. IS there some kind of power setting I need to change so I don’t damage my motors?

I didn’t change any wires, they just worked when I plugged them in.

The stepper motors were bought through ebay or amazon and are thebrand StepperOnline They haven’t been used before putting them in the LR3

Could it be your power supply? What voltage and current is it supplying? A photo of how your board is wired up can be useful as a sanity check.

That typically means a wire came disconnected. If that is happening, I would be more worried about killing the board. Steppers should not just die, they typically don’t ever actually die unless you drop them real bad.

The only other reason they would make this noise is your move or rapids are faster than the steppers can handle.

What else is plugged into the power port with your control board?
Any specific reason you used 12v instead of the 24v?

This could be a wiring issue / faulty connection. I had a wiring issue cause this type of symptom.

They worked fine and then just stopped working it’s happened to 4 now. Once I replace with a new stepper they work fine again.

There is nothing else plugged in just this adapter. I used 12V as I had it lying around. I could try and find a 24V if that would be better.

What did you set the current to in your config for these steppers you chose?

I have never seen a stepper die, and with stepper that big and drivers the size we use I don’t think you could unless you turned them up too high and they are doing a thermal shutdown.

I haven’t changed anything. How can I check what it is set to?

It’s possible it’s to do with my connections. I haven’t got the hang of making good connectors yet and some of them are a bit messy. My new stepper came with connectors already on and are a lot neater.

24V might be a bit better as you’d have less IR drop in the wiring to the steppers.

Thermal shutdown is an interesting theory.

I’m curious what you see in the terminal when the problem happens.

When the problem happens, shut down your router/spindle (So if the gantry drops you don’t drive a running cutter into the workpiece or table). Then do this in the terminal and report what you get back:
Start with this:


Copy the output in a reply.

Then prepare to send the line below:
(If you built an LR3 with the stock leadscrews on Z, the gantry will drop now- so be prepared.)


The above will disable the stepper driver chain.

Wait 60 seconds or so to let the system cool down. Then send the line below, and report what you get back.