Help needed: E1 pins not driving steppers

Hi there,

I have inherited a MPCNC from a friend who upgraded his home cnc setup and am currently re-assembling the system. I have physically assembled most of the system, purchased a new 12V power supply and have been function testing the steppers. However, it seems that whenever I try plug a stepper into the E1 pins and manually move the steppers using the manual move in Y axis it does not respond. I have tried different steppers on these pins, and tested each stepper on the other pins and they all seem to work except the E1. The E0 pins seem fine.

Has anyone encountered this issue? I’m thinking that maybe the Ramps board may be damaged in some way since it is an old build? Or the software version is outdated? Any help appreciated.

Photos attached.

Image of setup as I could only attach one image in original post.

Marlin version

On the Ramps board, swap the stepper driver between E0 and E1 and retest. If the problem stays with E1, then there is a Ramps or Mega issue. If it moves with the stepper driver, then you have a stepper driver issue. If the issue is the stepper driver, start by checking the vref voltage on the stepper driver. If the issue is with the Ramps or Mega, then I’d bet on the Mega being the issue.

Your firmware is a little out of date, but should still work.The Marlinbuilder releases page should have newer firmware for the RAMPS controller.

That said, the version that you’re on should work, and should control the dual Y axis motors (X2 on E0 and Y2 on E1.)

The RAMPS board stacks are reasonably inexpensive, at least.

Robert gave you some good advise on troubleshooting. You have already eliminated a bad stepper motor or wiring by switching the motors around, now you have to test the board and drivers.

Narrowing down to the RAMPS of the Mega2560 board is more difficult, I think, unless you have another of one of the boards.

If you do identify the driver as the problem, then another DRV8825 is easy enough to obtain, and should be inexpensive. If you are looking at replacing the board, I might suggest looking at one of the integrated boards. Though you can still get the RAMPS stack, an integrated board is maybe a little more convenient, and often allows for a wider range of power supplies. I used an MKS Gen L v1.0 for my Primo for a while, using the RAMPS firmware and DRV8825 drivers. You can keep the same 12864 LCD controller.

I’ve seen you make this recommendation before. How much did you need to change the Ramps firmware to run on this board? I assume it required some modifications?

Zero are necessary. Because I was running the DRV8825 drivers, it required no modification whatsoever.

I did make changes and recompile at first because I was using a 2004 discount controller at first, not the 12864. I also did include the full bed size in the recompiled firmware. I the 12864 controller, and then ran the firmware with no changes aside from the bed size, but it would have worked exactly from the binary firmware at that point.

The MKS board is a complete replicate of the RAMPS stack.

One of the things that MKS is known for is reversing the key slots on the EXP connectors. You will likely find that you would need to plug in the two 10 pin cables reversed from the way thst they are keyed, but a few seconds with a chisel fixed that for me.

1 Like

Good to know. I wish I’d asked sooner. I had to figure out how to cram a Ramps board in something a while back and this would have been a much better solution.