HELP! Machine went crazy, not calibrated.

As some of you may know, I live in Amsterdam, Had a friend help me build it, the friend is gone on his own journey, and I am not super techy but still really want to get my dear MPCNC fixed.

so suddenly on the x axis it seems to jiggle, kind of get stuck and lose a few mm on the design path, in an attempt to fix it, not sure why, I tighten a bit the screws marked with a red circle, this didn’t help at all, I’m adding an attempt of drawing circles, you’ll see how offset it goes and how wiggly the text comes out.

so first question is how tight should this bolts be (marked in red circle) ? as I touched them and not sure about that.

second question is an open one, what can it be in your opinion to get my machine so offset suddenly and how can I fix it ?




I also noticed if i just run the machine on x or y axis in straight linens, in some points the engine start stattering and don’t want to push anymore

Make sure the wires going to the stepper motors have a good connection. I can’t see the video where I’m at, but usually straight line stuttering is an electrical issue.

1 Like

Start with the crown gcode found on this page. That way we can eliminate gcode issues.

1 Like

Thanks guys! Will try what you proposed when im near the machine again, if i remember correctly even when i slide it by hand it was sliding somewhat rough.

Will update soon



So here is the crown test, few things ive noticed :

A)machine isn’t the cleanest but still problems started at one point and didn’t stop since

b) when I move it straight on Y axis for example, it seems that one engine gets a bit more stuck or slow, making the other engine stutter witch results in the Y pipe moving not straight.

c) I made more crowns, some came out better position wise but with very wobbly lines

d) the barrings on the pipes seems to not all spin together, sometimes it seems depending on direction that some bearing wheels aren’t spinning while others do even tough they are on the same group.


help :smiley:

Thanks for drawing the crown, using my gcode eliminates a lot of variables and really makes it a bit easier. I know for the king of drawing my crown if probably a bit…boring.

Okay, I see what you are getting at. The first two things to check are the pulley and the wire connections. For the pulley if it is loose it will be able to be pulled of the shaft, but usually still works just moves a few mm in each direction. As for the wire connections, triple check them.

A minor thing I see in the first video is some built up gunk on your belt bearings. That can cause some wobbles in your pen but most likely has nothing to do with it.

The bearings are for sure pretty dirty, gonna clean them one by one, just wd-40 and manually cleaning them i suppose? I did notice taking one bearing out, having it in my hand when I give it a spin it didn’t spin smoothly like a skateboard or spinner bearing and did just 2 spins and stopped.


In the first post I asked about the bolts holding the bearings, how tight should those be?


Our bearings have thick grease and don’t necessarily need to free spin. The bearing in the first video looks like it has some stuff you could just scrape off, the bearings that touch metal are pretty much self cleaning.

Tension is a bit harder to quantify when it is fully assembled. Each piece individually should be just tight enough that all the bearings touch. Not much tension actually, just enough… Sometimes, too much tension will make other bearings not touch, so over tightening can be worse than under tightening.

Semi positive update !

I tightened the little screws in the pulleys and it seems to have solved the position problem, lines seems to follow in place on the crown ? test, but still super wobbly lines, im not seeing any wires out of place or any broken wires for all I can see.

Any other idea on wobbly line solution?



i untightened the bearing screws a bit and the engine is now running better i think without getting stuck, just still wobbly results

Might have celebrated too fast, while crowns are looking better, when i simply move machine on the y axis, big stutters happens every once in a while, seems to come from right side of the machine in the video


Still looks like an electrical issue. I’ve seen the pins pull loose inside the stepper connectors. Double check again, then tape the connectors together and make sure the wires are taped as well.

1 Like

Are you using repetier host to control the machine or the LCD? The crown looks like it is drawing really fast, my gcode should be slower.

What board is driving it? Something seems fishy, the speed and accelerations seems wrong. It seems like you have a really bad connection or the board is actually not able to keep up with the commands. On the ramps boards it would do that if I tried to move at more than 150mm/s

Hey sorry Ryan, I should have mentioned that this is another faster Gcode I have made with the same design in Estlcam, running it slow isnt getting rid of all the wobbly lines, I am adding more photos that might help Uncover the mistery.

Shoot that is a lot of connections that could be going bad. It seems very likely that is the issue now. unfortunately you are going to need to check them all for corrosion or signs of issue. if a connection gets too bad it will pop a driver and will need to be replaced so keep the power off while you are poking around.

I would also get in there with some compressed air (computer dust off preferably) and give the board a good cleaning as well.

Switch to my gcode for testing, that just ensures there is absolutely no CAM issues.

it might be a good moment to ask the question, since as far as I could see all looks to me as it did a week ago when it worked perfect, I followed every cable start to end and didnt see any visible mistakes.

Are there any MPCNC users in Holland that would like to maybe come take a look ? is there a way to find them?, im unfortunately just an artist and the whole machinerie electronic side isnt my strong side especially when it comes to trouble shooting…

if there is any part I could buy to get things running again I would do so right away but I guess without me being able to spot the mistake its impossible to know what to replace.


I don’t have anyone’s locations so they will have to volunteer that info.

As for the connections it still works so what you are trying to find is a failing connection, even harder on a low power system, usually no burn marks… if you are unsure the easiest way is just to replace each wire from beginning to end, or I have plug and play wiring harnesses in the shop but international shipping is expensive.

Well luckily as im diving deeper and deeper into acrylic works with brush and not pen work or drilling, wobbly results are not an issue :smiley:


Im gonna still keep my eyes open and try spot the faulty part

Thanks for the help so far and giving me at least the precision back!

1 Like

So awesome.