Gcode or other problem

When experimenting with estlcam on RAMPS I noticed a problem. x- and y-axis are out of proportion/ratio. I tried milling a 40X40 mm square out of MDF, but I got 39x41.5mm. I thought it would be a problem with settings and stopped the experiment for that day.

Today I took the arduino mega with ramps on it (my experiment was on a new arduino mega) and wanted to mill a circle of 125 mm out of oak. I tried two, they came out as 124x131 (had the wrong bit selected in ESTLCAM) made a new toolpath and got 123x125 (right bit selected).

So it’s not a problem caused by ESTLCAM on the ramps.

TOday I tried the 400 square in MDF again, same results. Tried an 80x80 square: 79.3x80.5 and an 100x100mm square: 106.3x100.7.

I tested all screws for tightness, all steppers seem OK.

I had some leftovers from a couple of months ago, they are circles. When I check them the difference is 0.2mm when measuring x or y direction, which is very good.

What could i have changed?

As said I use ramps, repetier host as g-code sender and ESTLCAM to make my toolpaths. I will enclose the gcode for 80 and 100 mm square.

I hope someone has an idea to fix this.100x100.gcode (490 Bytes) 80x80.gcode (481 Bytes)

Belt tension perhaps?..also, what are the results like if you take less than 8mm in one pass?

Including the grub screws on the pulleys?

Jamie has a ruler you can draw with a pen to help you see what kind of issues you’re having:


Belt tension is as always, grub screws are tight. I will try the ruler.

The circles in oak were done in 2 mm passes