Fluidnc pen/laser board

Hello I was wondering if I could wire the connectors on my steppers from v1 as is to my fluidnc board? For instance the wire coding. Can I simply chop the end and install into the connector block as they were? They might be backwards but that’s a easy fix.

I couldn’t seem to find a TDS for the specific board with built in tmc2209 and just want to confirm.
I also seem to have two different wire designations. A-,a+ etc.
waiting on Amazon so trying to look ahead and get things progressing still.
Also I believe the end stops would go where the bad quality picture shows even tho it’s a slightly different board. Top right

1 Like

The names of the pins are a little weird.

Each stepper motor has two coils. Each coil has two wires. If you get the polarity of either coil backwards, the motor spins the other way. If you swap the two coils, then the motor moves the other way. So the only thing you really have to get right is that each coil is wired separately.

You should be able to just cut the end off and wire it in the same order.

But what that first image is showing you is:

  • X Motor: one coil goes from 1A to 1B.
  • X Motor: two coil goes from 2A to 2B.

Same for Y. At least, that’s how I read it.

If you want to know for sure which wires are a coil, you can tell easily. If you have wires v,u,w,x: v has exactly one other wire that is on that coil. If you connect that to the other wire for the coil, then the motor is harder to turn (it’s a weird thing, but very noticeable, try it). The other two wires are the other coil.


Thanks a lot Jeff much appreciated I just didn’t want to fry something and have to do the sit on my hands and wait thing lol.
Just need my darn belt to show up from Amazon lol

It appears I will have to use contact physical limit switch’s instead of the 3 wire optical ones.
And I can’t get my steppers to move. I can connect via wifi and I can hear the steppers kind of get powered.

I haven’t installed anything as I thought Bart guy did.
Am I supposed to install the recommended

firmware from the v1 sight as well.

I did get it out of “alarm” state by inputting the home code from the v1 site. And I don’t get any errors but no movement.
I did try and jumper the end stop ports as well to cancel out a NC switch there.

1 Like

You can still use the optical switches, just set them both to use the 5V pin, then grab the ground and signal pons from the switch connector. They will still work. The mechanical switches click while the ZenXY runs, and kind of disrupts the Zen


Thanks for the help it’s much appreciated.
Looks like I need more time to read up.
And that’s good news on the optical sensor. Just was trying the mechanical style to trouble shoot that being why my steppers would not move.
So neat how you can just hook up via wifi

I think I have found my problem.
I have not added a config file, I assumed it was on there bc of being able to link to the webui.
I found some good info for the other noobies.

I will try and get the confit file Ryan has in his site to download tonight.

The webui looks slightly different but I am sure there is somewhere that has the upload button.


Ok what I have done so far and where I am.

Bought board from Bart pen/laser tmc2209 with esp32. It came pre loaded from him, as I asked.

I got the board powered up with a 2amp power adapter.
I was able to connect to it via wifi. It came as a Wi-Fi network labelled “fluidnc” password default 12345678

I followed barts YouTube video posted above this thread. And entered my home network ssid and password left the ip address set as ADHC so I can confirm ip address change from the Wi-Fi chip on board.
I then reset and I wasn’t able to reconnect to the boards Wi-Fi chip.
I fumbled around trying to get linked via serial plug in on wifi chip. Some cords are just power cords and do not have data pins for info transfer. So be aware of that. I had to use my other computer bc this fluidterm and python program can’t run on win7.
So I got that all linked up finally after figuring out this “GitHub” thing and finding the files required on the fluidnc git hub.
I downloaded the latest zip file folder from there that contains some executable files for reflashing the chip via serial cable. I was under the impression I had to reset the board chip bc I had no wifi connection. I tried to erase everything and restart. And that’s when I found my basic problem. I was telling fluid term the wrong com port. So I went to device manager and confirmed that I was actually plugged into com6.
So I re ran fluidterm and entered the correct com port and it linked up and registered the board and had communication.
I had two errors due to me not having my 2a 12v power supply going to the board. Plugged it in re ran fluid term and I had no errors. And was able to confirm that I was in fact tied to my home network. So I was trying initially to link to a wifi address ip number that was not right.
I ended up using instead of accessing it via a ip number in my browser to access the webui. I had to use fluidnc.local (you can see in the fluidterm command picture the address at the bottom) on a computer with a newer version than win7. And then I had connection but still no movement.
Now I need to find out how to get my steppers to actually move. They are energized bc I can’t move them when board is powered.
I tried jumpering the end stop switch inputs on the board just to cancel that out and still no move.
So I am going to research a bit more and see what I find.
Also you can upload the config.yaml file in the web ui.
You need to go to the fluidnc tab at the top and it will show what is on your esp32 chips memory.
This is a way to confirm what config file you have etc.
also that has to match the name lower down on the list on the same menu.

Ps sorry for the bad grammar and spelling. I have a problem and I know it

Oh man. I have been there. I was working on trying to teleop a robot that was in Pittsburgh from Denver, for the first time. We had one wednesday where everything was a problem with networking. We couldn’t get any traction. On Thursday, everything worked. We both agreed we wouldn’t talk about that networking day until we were done with our demo.

It sure sounds like you learned a lot. The serial connection on fluidnc is pretty useful, even if you don’t have networking. I’m glad you got it connected.

Standard grbl will not move if you have endstops configured. I think fluidnc copies this. There is a button to reset it, which clears that flag. I can’t reach mine ATM, or I would check it.

1 Like

Haha oh man I just re read that back and what a disaster. I was in a fluster and just wanted to kind of log my effort so far. I will go back and clean up.
The network thing was such a wild thing I kind of tunnel visioned in on it and I thought for sure I messed a password up etc.
I am slowly learning that these videos and helpers are really only good for a small amount of time. Stuff is really moving fast and things are being altered almost daily.
I have movement tonight and I used your docu about sandify and tried to do a couple uploads but I feel like my mini sd is too large. I tried the format software Bart recommended on the git hub and still didn’t work.
I ordered a couple small sd cards and I hope that fixes the issue.
But as of now I have movement both steppers move and it’s being logged via the webui.
Learned a lot of stuff
What’s a pip
What’s github
What’s yaml
What’s fluidnc
What’s python
What’s fluid term.
It’s been fun and great!!!
Thanks again for all the input and help Jeff you and others do.

1 Like

Your list of new things included several of my favorite things. I’m so glad you’re plunging in.


I don’t know about a button, but $X unlocks the motors. I’m having fun with my older 2209 pen/laser board right now. the ESP21 programmed with Grbl_Esp32 died, so I’m trying to get it running on FluidNC, and I can’t seem to talk to the drivers…

1 Like

Idk if he is talking about the alarm lock out.
But I had to either enter the starting code that Ryan has on his site first to let the steppers move.
Or you can press the alarm button and it will clear that so you can jog etc.
sorry if I am just confusing things.

1 Like

Alright what I have now.
8gb mini sd that works the others larger ones did not.
I put a basic sandify file I had done quick. And I got a feed rate error on line 41.
Then I tried Ryan’s sandify logo file gcode
And it just sits there and times out after a bit and goes back into alarm mode.

I will have to have a peek at the gcode file maybe it has something to with with end stops.

I am now not knowing what’s happening.
I thought I was good to upload some gcode and apparently not :frowning:
Now I assume that fluidnc accepts gcode like marlin etc. but it clearly isn’t that simple.

What do you have is your starting gcode?

I had just downloaded one of the patterns on the v1 site.
I will have to do some reading up on this i remember Ryan having issues with the ending code stopping things or something.
Can you not just like enter a x movement and have it go or is there some code it has to see first to move

For mine, in the serial console it says to either home the machine $H or send an unlock $X to unlock the machine and move the motors. I dont know if homing individual axes would allow the machine to move.

1 Like

I tried a couple different start codes
Like was recommended on the v1 to no avail.
I am confused to am I supposed to use grbl format or gcode ?

I tried the unlock code and it worked still no move tho
Ok so weird I think it’s working now

A sand table will probably work best if it is homed first. You may not want to just start from wherever you happen to be.