Firmware needed for Archim2

I, for the life of me, cannot get any firmware to flash on my Archim2 board for the LowRider2. I keep getting the same error:

#error “Archim2 requires Software SPI. Enable TMC_USE_SW_SPI in Configuration_adv.h.”

It’s frustrating the living $#*@ out of me. HA!

Any help would be appreciated.

As the Archim 2 has Trinamic TMC2130 drivers internally installed it requires the firmware to have TMC_USE_SW_SPI enabled in configuration_adv.h…as the message tells you. You are going to have to configure and then compile your software for your board of find a different firmware already compiled for your board, perhaps someone who has gone through this process will pop up and advise you.

The Marlin Builder has a configuration for archims on marlin 2.0.6. It only builds in platformio, not arduino.

We do not have firmware for this board.

If you wanted to start with our archim 1 firmware you will need to edit the files. configh, board type, driver type, steps per mm (maybe more). Config adv, you will need to at least set each drivers current.

What of those stpes are you missing, what have you tried?

I’ve only played with the line Archim2 file on GitHub for the mpcnc. I tried Arduino, then Platformio. I couldn’t figure it out and I’m not 100% sure I can set something up on my own.
I appreciate your help. I think I misread one of your posts to mean you had an answer to my problem. It was probably more wishful thinking on my part. :wink:

What is this?

Lone… Not line.

On GitHub there’s one file for the Archim 2. Just following the links from V1’s site.

I really appreciate the help but the more I think about it the more likely I’ll just wait for a preflashed board to come available. :man_shrugging:t3:

That file is extremely old.

I can’t believe someone does not have a more current version. Let me change the title to try and get more attention.

I am swamped right now and not having one of these means I can’t really quickly test anything.

I don’t want to nay say, but when I was looking through issues in Marlin a few weeks ago, there were 1-2 about the Archim’s not working right in 2.0.6. They would compile (which we are testing), but they wouldn’t act right after that. I have no idea if this is people not understanding what they are doing wrong, or if there is a fundamental bug in the archim code in the most recent versions.

1 Like