Feedrate limits in firmware

I run a mpcnc primo with skr1.2 pro and the tft screen. Lately I have been cutting mdf. The cuts are going good but it feels like the machine can handle higher speeds with the mdf.

I tried to go 60mm/s with the vbit as there was no resistance while.cutting.

I use estlcam and i set the feedrate but it did speed up the cut.

I’m not great st f8rmwwre at all. But I searched the site and the forums and located where it talks about feed rate in the firmwar.

In the picture is that where I can change the limits of the axis speeds.

I have also changed the rapid movements in estlcam howeverenut does not seem to speed it up anymore.

If changing these is not the way to go is there other ways to spend up the cavre. Especially vxarv8ngnin estlcam during the carve pocketing it takes for ever eith the little pecks.

It is easier to change that limit with gcode

M203 X50 Y50

That will set these to 50mm/s.

If you like it, save it with M500.

You can use repetier host to send these commands. Or through the terminal in the tft screen. Or in the settings in the marlin mode on the tft.

O cool, I was digging in the firmware and did change it from there but it didnt seem to change anything. This will help in the future for sure.

I’m cutting mdf and it’s been cutting the 50mm/s really easy

Changing it in the firmware can change the defaults, but often it will just used what is saved in eeprom. So that’s probably what happened. M502 will delete whatever is on the eeprom and load everything fresh from the firmware. M500 saves whatever is running to eeprom.

Thay makes sense. So I changed the speeds in settings then did a run. Do I need to initialize eeprom or will the settings I type in stay after I unplug it.

Inchanged them from the screen under advanced settings. It ran smooth and quick. Only issue inhad seem is the depth didnt gonas deep in my middle. I’m hoping the mdf was just cupped there as unlike how fast it is cutting.

I’ll do a couple more at these settings and see if it stays accurate, it didnt seem to skip steps at all

M500 will save whatever is running to the EEPROM.

There is also a menu option called something like “Save settings”.

How would I check what speeds my current eeprom are set as?

Use M503. You need to send it from somewhere that can output the data…like Repeater-Host.

1 Like

I don’t use Repetier-Host, but are you sure you have the output endabled?


Got it working, lowered baud rate and seemed to work

The baud rate should be 250,000.

Yeah should be, but when I lowered it to 115 it seemed to get the response :man_shrugging:t2:

Frank, what are you seeing? Why are you posting on this topic?

115,200 indicates that you are not using our firmware.