estlcam - unable to adjust depth on text

For some reason I cannot get estlcam to give me the right depth on text. No matter what I do I always seem to get a depth of Z-1.5875. Please look this over and see if anyone can help

I select a tool that has a depth of 10mm. (I am cutting in foam).
I set up text with a cutting depth of 10 mm

I type in the text and preview and it looks like it is only a couple of mm deep.

I check the gcode and it shows Z of -1.5875.

When I run the code with repetier host it comes out shallow.

Any clues?


[attachment file=“Jane.docx”]



weird. Can you post the estlcam file?

Do you mean the project file? Here it is.

The forum would not allow me to post a file with extension .e10.

I zipped the file up and that extension is allowed.

 (335 KB)

Thanks for posting that. I opened it up, and it’s doing the same to me. I have a slightly older 10.something version of estlcam installed right now.

TL;DR, click on the letters, and choose “Pocket Inside” instead of “Carve Inside”.

It’s got carving selected, which is what you’d do if you were using an angled bit. The angled bit would allow it to get into the corners and raise up a little, so it would make a point in the corners. With a flat-bottomed bit, you can’t do that, but something in the math of estlcam is thinking it’s going to try, even though you’ve set the bit size to be 1/8" and 90 degrees. That math is coming up with a max depth of 1.5875 or whatever. It thinks it can’t go down deep enough to fit the bit in the letter at 10mm.

If you want to have more control than that, then I suggest making the letters in another program, like inkscape and loading them into EstlCAM as an svg or dxf. If you just want to write at 10mm, then just choose “pocket inside” instead.

1 Like


That looks like the clue! I never even looked at those options. I have not had a chance to try it out but the preview and the gcode certainly look like it should work. I’ll try this on my machine first chance I get.


An update. I tried the suggestion provided by Jeffeb3 and everything worked as desired.

Thanks Again.