Estlcam Pocket Depth on LR2

Hi brilliant folks,

I’m running a pocket on Estlcam and cant seem to get it to stop going all the way through the wood. It never stops at the 1/2" or 12 mm depth and continues all the way through. Can anyone tell me what I"m missing here?

Pocket I want to cut at 12 mm deep:


Here’s the steps I set

Estlcam Basic Settings:

Tool set in Estlcam:

Pocket Settings for Hole 1

Material Thickness was set to 20 mm

Starting Position of Router set to Z/x/y = 0


Gcode for first hole generated by Estlcam:

M03 S22000
G00 X0.0000 Y0.0000 Z20.0000
G00 Z25.0000

G00 Z25.0000 F3683
G00 Z20.5000 F3683
G01 Z18.7300 F610

G00 Z19.2300 F3683
G01 Z17.4600 F610

No. 1: Hole 3 (Z code basically with X/Y Stripped out
G00 X57.8941 Y23.3349
G00 Z20.5000
G01 Z18.7300 F610 S22000

Last Code for the hole…

G00 Z25.0000 F3683

G00 Z9.0700 F3683
G01 Z8.0000 F610
G01 X57.7127 Y101.0871 F3683
G02 X111.0662 Y53.5194 I12.9452 J-39.1856 F3683
G02 X43.1947 Y31.0978 I-40.4083 J8.3820 F3683
G02 X57.7127 Y101.0871 I27.4632 J30.8037 F3683
G01 X57.9215 Y100.4874 F3683
G00 Z25.0000 F3683

If you are starting at the surface of your table, your starting level is not zero. It is the height of your material. Have a look at my intermediate instructions on the how to page as I do a table level walk through.


PS, Always use a finishing pass.

Thanks Ryan- checking it out now. Sorry for the double post.

Ok, I looked over the instructions but I think there is a misconception with my picture. That is a waste board that is considered at bed level where the bit is set.

So the bit is set to 0 on the bed level at this point.

0 should be set to the upper surface of the part you’re cutting.


Also just noticed your z origin is wrong in repetier.

Ok, pardon the denseness - This was my new settings:


Not sure what you mean-
“Also just noticed your z origin is wrong in repetier.”


Barry- That is lift height I believe over the work piece at 20mm right?

ok- for the record that did NOT work right. That plunged the bit all the way to Zero. So- going back to read again as I missed something somewhere apparently.

I see what you’re doing now. You set the zero at the table, then your start level is the material thickness. I’m not sure if it can work that way. Generally everybody here is setting the origin to the material surface, I think that’s what it says in the Basic Settings in estlcam, you have table surface in the picture a few posts up.

Change the setting for “Z axis origin” to workpiece topside and don’t set the starting level.

Sorry Allison, I meant estlcam when I said repitier…

[attachment file=“remmina_screenshot-2018-11-26-18:20:11.217811.png”]
Hopefully this is still readable, it’s two remote desktops deep through a vpn to the house…

Jeff. what you are saying is flip the setting to Z axis Top Side and then set the bit just slightly above the workpiece (.5 mm or such)?

Yes, but you also have “start level” set in your toolpath to 20mm. That should be zero.

You can have the bit touching the top surface when you reset the Z0. 0.5mm above is fine. The top surface of my workpieces has wood grain, so it’s hard to get more precise than that.

OK- once I get this I think I"ll be fine for a while btw. Here are the settings that I used on Hole 1- It still went through the workpiece.

I set the top of the bit .5(estimated) above the work piece. I then set the ZERO axis to z/x/y = 0

The depth set on the question when it asks for depth is 20 mm. I have an outside path I cut all the way through with tabs.

Okay, all that looks right now. So the next question, if you raise Z say 20mm, does it really go up 20mm?

Yes it goes up the 20 mm

Ok, so when I raised the the Z axis up 20 mm it works fine. It does go up and down and seems to measure out fine. So I tried a ‘print’ and here is what I had happen.

Z axis passes from pass 1


On the Final 11.99 pass, i think the router went down deeper into the cut. It’s as if the Z axis sunk or something.

Here is the final pass and what it looked like on the last circle around the hole. Also, you can see that it had dropped from the zero point and went through the material instead of coming up above it for the second hole (top right of pix)



Try cutting your Z feedrate in half. Now that I see it’s not going back all the way up, it seems to me to be losing steps.