Estlcam full depth full width cut


Really weird issue with Estlcam… Just before the finishing cut it tries to make a full depth full width cut along the side of the piece it’s cutting… This of course is way too much and causes the bit to veer and gouge the piece…

The part I’m cutting is essentially a box with some rounded troughs cut in (a box for turned pens). I made the part in Fusion360 and exported an STL which I then pull into Estlcam to generate G code. Cutting at 1.5mm depth and 12 mm/sec with a 1/8" 2 flute rounded up cut bit.

It’s not skipping steps because the rest of the box is cut fine and the finishing pass works fine.

I cut it with the length along the Y axis and then tried it along the X axis. It does the same wonky cut at the same place either way so I know it’s something Estlcam is doing and not hardware.

Thankfully Ive been testing on 2x4 fir and not the aged pecan the order calls for.

Anyone seen this before or know what setting would cause Estlcam to try and dig in like that?

That is the cutout for your part correct?

You should be able to set your step down with the tool settings.

Here’s one I just took off the CNC. It was oriented with the length along the X axis. This time it dug in 3 times. It’s almost as if it’s calculating the opposite direction to move for the finishing pass. Instead of just trimming a little bit along the edge it’s putting the whole width of the cutter through. Maybe a bug? I’m using the block cutting method and leaving everything default/automatic. The Z stepping is set to 1.5mm depth and 2mm speed. The rounded troughs cut perfectly. The initial rough cut cuts perfectly… Just the finishing pass is weird and only along the length.

That is odd for sure. Are you using the newest release? Either bump up to the newest of go back like 5 and double check. Just to verify. If you have found a bug and can confirm it I am sure Christian will fix it asap.

1 Like

I haven’t every done 3d, but is it possible to do the border part in 2d? I wonder if it thinks the board of smaller than it is.

You should be able to look at the preview first and see if it’s trying a full depth cut.

1 Like

I wish there was a way to do just some of it in 3D and the rest in 2D. Really all I want are the troughs and I can cut the rest on the table saw. I haven’t figured out how to do that yet…

Just ran it through CAMotics and played the Gcode… yep, definitely something weird going on. It gets through all the roughing just fine, then goes back to the first corner and bores down into oblivion and then reappears at the opposite end and rises up through the table…then goes back down, back to the first corner, then back up to the top… Then completes the finishing passes perfectly

What estlcam version are you using?

I just checked with 10.039 and it looks good. Are you sure you stl is manifold, how did you generate it? Maybe too high of resolution? does a 3d printing slicer or netfab see any issues?

1 Like

This is kind of a hack, but you could just delete the gcode after it does what you want.

1 Like

I am exporting out of Fusion 360 using the 3D print option. I leave everything default there.

Opening in Simplify3D seems to be fine. Doesn’t have any issues with the STL.

Downloading Netfab now…

I’m running Estlcam 10.046

Turning on the transparent model option in Camotics I think I see what it’s doing… It is moving inwards roughly the full width of the cutter but also boring down to the bottom and making passes upwards… So instead of starting at the top of the material and working it’s way down, it’s trying to start at full depth and then come back up.

I found where Estlcam will allow a dxf mask to be used to only machine what you want… I’m going to figure that out so I can just cut the troughs instead of the whole box. Also, I tried free machining rather than block machining and it cut the margin completely different…Seemed to work correctly from what I can tell… Camotics shows some weirdness in the same spot, but it looks to cut in the right direction

This is a good idea. I could just delete the finishing pass code for the sides and just leave the top and troughs… Thanks!

Heres the Estlcam settings for free machining and block machining

Maybe try taking the finishing settings out of the tool since the 3d milling does it’s own version.

Again, he has changed a lot recently you might want to try a few previous versions to see if it is an estlcam bug or not. You should not have to do all these extra steps, carvers are generally the easiest to do.

1 Like

Heres the STL files… check out the difference between block and free machining… In the block file, around 40% into the timeline right after it does the roughing it gets weird…bit plunges… In the free machining file it seems ok but theres like an overhang or something… But it least it doesn’t bury the cutter into the piece. (17 KB)

You should be using free machining, block is for 2 sided objects.

1 Like

Just tried 10.039 and 10.041… Same deal. When using block machining its like it ignores its working margin (which is twice the width of the bit) until right before it makes the finishing passes and then it tries to cut the rest of the margin starting from the bottom… In free machining it doesn’t do this… It cuts the margin as it descends through the piece.

I really like that CAMotics software. Works great for this. Weirdly enough it doesn’t like the gcode for our plasma cutters at work (generated out of CAMduct, PMcut, or Vulcan).

I am a chicken as was taken in by its “mostly automated” vs the “set parameters manually”… I’ve used it before but just uncheck the 2 sided machining. Seemed ok. Of course this is to make some expensive stuff for the big boss of our company and thats when it decides to give me some grief. Free machining it must be then… thank you sir! :slight_smile:

I am not 100% on this stuff, I have been pretty glued to my chair recently and have not done much milling. I just know block machining is new and the last 3D I did this was not available.


I do think it is a bug and should get brought to his attention. I will see if I can break it and if I can I’ll let him know.

Got a chance to cut the free machining file… Other than burning a little (RPM up too high I think… I usually run it slower) it cut just fine and in the correct order.

Sweet the other block machining might not be a bug it might have to be flipped or a goofy setting. I will try and have a look at it the next time I go get dirty.