Estlcam Crown gcode file moves the CNC too much

Hello community,
Brand new user here. My son and I are trying to get a MPCNC up and running for his robotics team at high school.
We are trying to do the crown and having an issue that when we run a gcode file that is generated in Estlcam and run in Repetier the MPCNC seems to move way too much for each movement. It moves way to high up in the Z direction and then starts “drawing” above the paper. The X and Y movements are way too much. I can’t tell exactly how much but on the order of 2x.

We have the RAMBO 1.4 purchased from V1 and preloaded with Marlin.
Running most current Repetier Host
Running most current Estlcam 11.244_a_64

Repetier seems to be working properly. All motors are moving in the correct direction. As best as I can measure with a ruler, we are moving the correct distance in X, Y, and Z with the manual jogging. We manually jog the pen to our 0,0,0 before loading the Estlcam gcode to run the crown. The crown looks good on repetier as far as size.

I am a new user so I can’t put a link, but I have a google drive folder with my gcode generated. I could maybe message it to someone if they want it?
I can only embed 1 photo also so I put my CNC program settings from Estlcam. If something else is more useful to see, let me know.

Any ideas why the code generated would be moving the pen in this manner?

Thanks in advance for the support!

Hello there, and welcome to the forum! Nice project you’ve got with your son, I hope I can have the same when my son and/or daughter grows up.

Have you followed the docs precisely enough?

The size are sometimes messed up because of different units (in/mm) and different scaling. If you measure the crown with the middle mouse button in estlcam, it should tell you what size its working with. If the estlcam sizes are good, it’s probably something going on with repetier høst. Try to run the gcode from sd-card instead and see what happens.

Good luck!!

Thanks for the reply!
I measured the Estlcam file and it seems correct 155mm wide and I was shooting for 6 inches or so. That sees correct. I did follow the page you were showing as best I could. I think I got everything setup with the units mentioned. To your point about trying to run from an SD card, if I don’t have an LCD screen how would I run from an SD card rather than Repetier host?

Ah, the sd-card won’t be of any use then! It certainly sounds like a problem related to unit conversion. If you made a 1x1cm square in Inkscape, exported it to dxf14 and run it through estlcam-> repetier, would the drawing be 2.54 cm?? :grinning:

If nothing works out, what about trying cncjs? My favorite, run on a raspberry pi with @jeffeb3 s v1p1

Start with the gcode made by Ryan. The test crown should be used to eliminate any problems with the generation of gcode and just check out the machine.

Once that is working, we know it is a setting in estlcam, or something with the start procedure.

I will do that tomorrow thanks!

I am going to try a couple more things suche as @jeffeb3 susggestion.

For my own knowledge does cncjs work with Marlin or would I have to put new firmware on the RAMBO?

Cncjs does work.

Also first robotics is awesome. I forgot to say that in my first post.


The test crown worked as intended. The next step we drew a simple 3" long square and saved it as a .DXF. We opened it in Estlcam and made an engraving gcode. We ran that with Repetier and it worked! Not sure what was wrong with the first crown, but we did scale it a couple times in Estlcam so that may have something to do with it, but either way, I think we are good.

Thanks to @jeffeb3 and @turbinbjorn for the suggestions and help!

And yes @jeffeb3, first robotics is awesome. I wish they would have had the program when I was a kid.