Error flashing Marlin 2.0 to Rambo 1.4

Hi! I have recently build my own MPCN. The issue is that I chose the Rambo 1.4 motherboard, but every time I try to upload marlin through Arduino IDE, I get an error message saying “Error compiling for the Rambo motherboard”.
I have tried several times, following the instructions of V1 Engineerig step by step, and I don’t have any idea of how to solve it.

Thank you very much!


You might check all your Arduino IDE settings, with regard to:

  1. your board libraries, make sure you have one installed that includes your particular board. I have learned, for instance, that not all “Mega” boards are exactly the same. Especially the really cheap knock-off ones.

  2. your programming port is correct.

You can also try the “Verify” command instead of the “Upload” command. It’s the “Check-symbol” icon on the left of the icon menu. If it will compile without generating the message then it’s likely one of the two things I listed.


1 Like

Thanks for your answer. The board is a cloned RAMBo. I have tried compiling setting the board as RAMBo (installing the rambo boards library, as the V1 Engineering instructions says) and also as ATmega 2560.
Still not working.

Have a look at our platformio page.

Thank you. I have uploaded marlin with Platformio witn no errors. But I still got the problem that when I plug the board to the pc and open Repetier Host or Pronterface, they recognize the motherboard and connect with it, but the motors don’t move…
Sorry, I’m pretty new at this stuff.

Do you have power going to the motors also?

No, they are directly pluged into the board

The power from the mains should be plugged into the logic and motors area on the board

1 Like

I thoug the motors could be pluged just with the 4 colours cable into the board, with no external drivers

It also needs power coming from the mains.


Perfect! Now it is working! Thank you very much. Now I only have to clone the X and Y brhaviour to E0 and E1 ports…

1 Like