Endstops, what am I doing wrong?

Been setting up my primo and was hoping to get the endstops working, but when pressing home x/y axis it just moves 10mm and stops. Z axis works fine.

Check the state of the endstops with M119 first, and confirm the coordinates are right (negative X,Y goes towards the endstops).

I may be stupid now, but what is M119?

It is a command you can send, and the controller will respond with the measured state of the endstops. This is from the printer I have on my desk:

Reporting endstop status
x_min: open
y_max: open

If you connect a computer to the controller, you can connect repetier host to it, and put M119 in the Send Gcode area. The controller will respond in the logs on the bottom.

If you can’t do that, you can try to post some pictures of the controller, and the endstops and we can see if there is something obvious.

Your description sounds like you wired your endstops as Normally Open rather than Normally Closed. The movement is the firmware trying to retest the endstop position. But Jeffeb3’s suggestion of an M119 will tell you what is going on.

Thanks, I will try that when I get home from work.

Do I need to config the “bed size” though arduino to change it. Above 200x200 it doesn’t home.

It’s not absolutely necessary. You can just move the gantry within the “homing area”, before you home. But if you want to be able to home from everywhere, the settings must be changed. I think there’s an gcode to change the settings from terminal straight to eeprom, without needing to flash new firmware. But I can’t find it, might be wrong… @jeffeb3 ?

I fixed this problem by changing the firmware and re-flashing. In configuration.h you will find:

// The size of the print bed
#define X_BED_SIZE 200
#define Y_BED_SIZE 200

1 Like

Nope. No gcode for bed size, that I’ve seen.

1 Like

Ok, thx again.