End Stops issue - again

Disregard. I’m likely stupid.

I do need to figure out the Z axis homing thing, though.

Touchplate, or an alligator clip and a thin piece of metal.

Ahhhh, gotcha. I’ll figure that out later. Now I have to figure out the original issue of the end stops not actually stopping motor movement. Dual End stop, RAMBo, All hardware purchased from the store. X_Min and Y_Min are reporting correctly but the motor keeps spinning when the end stop is hit. Max switch does nothing to stop motion, either. It’s seeing them, they’re just not doing anything.

The endstops are only on during a homing move G28 X Y. Make sure they are on the correct side they should stop the motor on the same side as them.


Just because I am dumb sometimes, but would you mind doing a quick sketch of where the end stops should be located.


Have you seen this page?



I have my Z stop set and working but I cannot get X and Y to work. When I issue G28 X Y, I get a few mm of travel away from 0,0 but no return to the end stops. I have tried NO and NC on the endstops to no avail. Any suggestions as to what to try next?

That means it thinks the endstops are triggered. Normally that means you wired them wrong but you say you tried it both ways. I would verify with an m119 to make sure open is open and triggered is triggered. XY are NC, Z is NO.

They are reporting triggered no matter what. Even unplugged completely from the Rambo.

1 Like

What firmware do you have flashed? Maybe re-flash it just in case.

Any chance you have a really big solder blob behind those pins?


I refreshed the board to


I got all of the end stops reporting correctly, but it still will not return to the end stops when I home. Any thoughts or ideas of what to try next?



What does this mean? What do you do and what happens?

You should open repetier, home X only and see what happens.

If I home X in repetition it will raise and move maybe 5 mm. Maybe I am thing wrong, but I thought it should return to the endstops which I would assume would be the home position.

Which way does it move towards or away from the endstops? Since you say 5mm I assume it is away, you have the micro switches wired wrong. M119 should show open when not touching the stop blocks. Wired correctly it will try and move up to 200mm towards, wired wrong and it moves 5mm away trying to “un-trigger”.

Ok. I was going by the fact you said earlier they should be NC. I will reverse them and try again in the morning.

They should be normally closed, Which way does it move, when not touching what does m119 say?

You almost give enough details to help but not really.

@Ryan - when I downloaded from your github last week, the configuration.h file was set up for NO endstop contacts. I changed both X_MIN_ENDSTOP_INVERTING and Y_MIN_ENDSTOP_INVERTING to false to match the comment for NC connections.

I am trying to ask simple firmware non-dependent questions. You keep asking questions but you have not answered any of mine so this is getting really complicated. You should not edit any of my firmware files or you will make it even more complicated.

1-When your gantry is not touching the endstops exactly what does M199 return in it’s entirety?

Ryan -

I think I may have confused things up a bit and I apologize for that. I was trying to say that the OP may have the endstops wired up NC but downloaded firmware from your github that was not setup for NC endstops.