Dual Endstop setup jerky/rough movement with E1 for Y2

Swap Y1 and Y2 at the control board. If the issue moves to the new stepper, then you likely have a wiring issue. If it doesn’t move then you either have a mechanical issue (grub screws on the pulley are loose for example), or the stepper driver has a problem (bad or the v-ref is not set correctly). You can then swap the stepper driver at the board to determine if the issue is with the driver or a mechanical issue. It is exceedingly rare for the stepper motor to be the issue.

I’m assuming you have the dual endstop firmware correctly installed. If not, neither X2 or Y2 will be powered.

Thanks for your reply Robert.
I did troubleshooting from all aspects. Plug a motor directly into the board and it behaves the same way. Also swap the driver and it works in the new slot - Z - but the z driver does not in Y2 / E1. Motor, cables and driver swap yield the same result. Tried 4 different motors, swapped X and Y setup, problem moves with the board socket.

So, if I understand correctly, you’ve eliminated everything but the socket. If it happens to a single stepper plugged directly into a driver that is determined to be good (by swapping), then you likely have a board issue. I don’t know what to tell you other than to look for a bad solder joint. If it only happens when Y1 and Y2 are plugged in, then look to make sure you have the microstepping jumpers set correctly under the stepper driver. They both need to be same, and the V1 firmware is expecting all three jumpers to be set.

Looks like my full description of the issue incl. software got lost.
Running dual endstop version
The same driver works in other sockets fine.
I have two new drivers, the problem is the same with the two new and one old driver in E1.
By process of elimination I identified the driver socket / E1 connector to be the source of the problem.

I shared the picture. Do you see anything wrong with the jumper?

I don’t see any jumpers at all in the picture you provided. At the very least, the drivers need to match between Y1 and Y2, and the V1 firmware is expecting jumpers on all the pins for all the drivers. See this picture. Three of the five drivers are fully jumpered, two have no jumpers (so you can see the difference). You are looking to have jumpers on all three pin pairs for all five drivers.

Note the jumpers may not be the cause of your problem. It would only casue the problem you describe if the number of pins jumpered was different between the two sockets. But the V1 maintained firmware is expecting all three pairs to be jumpered.

I added 3 jumpers and it works like it should. Did not realize I was missing a step.
Thank you for your help.