Dual endstop firmware and rapids

I updated to dual endstops, and everything works great, except my rapids (G0) commands are super slow now. I verified that the gcode is correct. Is there a firmware limit I need to set/update somewhere?

Here is a snippet that is moving really slow:

G0 X60.510 F2000 Y45.833 F2000 Z6.350 F500



You can’t have two F commands per line as far as I know.

3? What software are you using, that will not work.

VCarve. This used to work on the old firmware (or seemed to anyways). I updated the postprocessor to break those commands up to multiple lines to see if that will fix it.

Separate lines will do a square move instead of diagonal. You can’t do that.

There is a verified VCarve PP I just tweaked a week or so ago. It made proper GCode as far as I can tell.

I meant breaking out the Z moves to a separate line. That should work, right’? Like this?

G0 Z6.350 F500
G0 X60.510 Y45.833 F2000

Provided you are not doing a 3D carve. I am looking for the file…

Not sure but they should use the same post processor.

I’ll give that a try. I wasn’t sure by reading the thread. Do you know if the arcs version of the postprocessor worked? It might be nice to host the file in the git repo. There are a lot of versions floating around, and I have taken bits and pieces from older ones to get mine working.

You will have to try I have never used that software.

Having both versions is a really good option as small arcs tend not to work really well. I need to find a way to tune marlins arc functions better.