Do you need a control laptop?

Good morning folks :slight_smile:

Just curious do all of you use laptops or something with your CNC?
I had planned on just using gcode and putting the SD in and running it.
The biggest problem I have is that when I move the axis around i have to power off the machine to 0 the axis again (without a gcode command available).
Of course that means to start the cut it moves back to 0 0 0 .
Im sure I could do it off of an ipad… Is there any control software with Ipads that would allow me to enter gcode commands and move axis etc?
thanks

I have a raspberry pi mounted to the wall above my workbench as a shop computer. Then I have another raspberry pi attached to the rambo running the v1pi image and cncjs. Cncjs controls the cnc, I control cncjs via wifi and a web browser from my shop computer.

Im sure it works well, just seems a bit more than I need :)…
I have a chromebook laying around down there too, right now I use it for my duet wifi based 3d printer… but i could use it for this too, if repetier or something had a chrome os app haha.

Oh sorry, I thought you were asking for our setups. I understand where you’re coming from. I’ve never tried to run my machine from just an sd card an couldn’t imagine not being able issue my own gcode commands.

I did a quick google search and didn’t find any gcode sending apps for ipad or chromebook. You could use just one rpi, not two like I’m using. If you’re handy with electronics you could make a pendant.

[edit]
I spoke too soon. Here is a chromebook app https://chrome.google.com/webstore/detail/gcode-sender/ngncibnakmabjlfpadjagnbdjbhoelom?hl=en

Hasn’t been updated since 2015 though.

Here’s an android app to work with grbl https://play.google.com/store/apps/details?id=appinventor.ai_ploy_panmaneecnc.GRBL&hl=en_US

But I assume you’re running marlin?

On the MPCNC, I just us the LCD and gcode files on the SD card.

Technically, if you want to do custom Gcode commands, you could just have a couple of gcode files on the SD card with the typical commands you want to run. Load the file and tell it to ‘print’ and the file would run like a macro.

On the Laser Engraver running GRBL, I have a Raspberry Pi running cnc.js. Then I connect to it from the shop laptop to load and run everything.

I’m still in the “contemplating” stage of adding another Pi to the MPCNC to run cnc.js. I’ve been running it since 2017 without one, so not sure why I feel the need to add one now.

So I created 1 file that is Just G92 X0 Y0 Z0
So that worked… it zerod out the axis before i started…
Made my cut and VOILA

However After the cut, the X axis just started moving back to the Left, and WAYYYYY past its zero.
I have this in estlcam as the post code
G28
G92 Z20

It should just go back to 0 and raise up the Z to get it out of the way. It went WAYYYY past zero. i had to panic and pull the plug, which didnt stop the endmill and it drove in to my table haha.

G28 is a homing sequence. The machine will keep going until it hits an end stop.

If you do not have an Endstop, then you need to remove that from your code.

My Endcode on all my Gcode files are

G0 Z15
G0 X0 Y0

This will raise the Z 15 mm and then go to X0Y0

If you’re running Marlin and have the LCD connected, go to Custom Commands, there is a “Reset all Coordinates” entry that will set the current coordinates to (0, 0, 0). I think that does what you’re looking for…

1 Like

Ok, David… thank you… not sure how I missed that :slight_smile: thanks