Difficulty Flashing Dual Frimware RAMBo

I have been banging my head against a wall trying to flash the dual endstop firmware on the RAMBo board I got from v1. I’ve used the Arduino IDE to flash my Ender 3 board and the SKR Mini Upgraded board I got for the E3 so I know it works. I must have forgotten how to flash or something because I can’t get the code to compile and upload.

I followed the instructions here but kept getting an error like this:

avr-gcc: error: CreateProcess: No such file or directory
Multiple libraries were found for “U8glib.h”
Used: C:\Users\jtoon\OneDrive\Documents\Arduino\libraries\U8glib
Not used: C:\Users\jtoon\AppData\Local\Arduino15\packages\rambo\hardware\avr\1.0.1\libraries\U8glib
Using library U8glib at version 1.19.1 in folder: C:\Users\jtoon\OneDrive\Documents\Arduino\libraries\U8glib
Using library SPI at version 1.0 in folder: C:\Program Files (x86)\Arduino\hardware\arduino\avr\libraries\SPI
exit status 1
Error compiling for board RAMBo.

The complete log can be opened here.

Am I doing something wrong? I erased library folders but that would give other errors. I’ve uninstalled arduino, wiped all libraries and rebuilt the IDE with no success.

This is a problem with the latest firmware from Marlin, along with the windows and arduino environments

  1. The board should have come flashed from V1. Is there a reason to flash it again?
  2. Check out the preconfigured zip files in MarlinBuilder releases. Those have this problem worked around.
1 Like

It seems to not have the dual end stop firmware flashed on it. I’ll wire it up and only 1 stepper moves per axis.

Aha. I think he only flashes the dual endstop firmware if it comes with a dual endstop wiring kit or something. I think he writes D or S on the box for dual or serial firmware.

Yeah I believe I bought the board whenever it was in stock briefly earlier this summer in hopes of it kickstarting my burly build. Then primo came out and I printed and bought the rest of the parts.

I’ll give your link a go and report back later tonight.

Downloaded the dual endstop preconfigured Marlin and flashed it and we’re good to go. Thanks for the help @jeffeb3


Hey @jeffeb3. I have been dealing with the same issues all weekend trying to solve the problem. Guessing my RAMBo is from V1, but did not look like it had dual endstop firmware preloaded. I can’t seem to get Ardunio to flash the board so I decided to try utilizing the PlatformIO with VS Code. VS code seemed work in actually flashing the board, and both steppers are running on each X/Y axis.
Now I’ve run into a new problem though. My LCD screen is no longer working. Just a solid blue screen after loading the latest version for RAMBo. LCD was working just fine with the original firmware on it just so that is clear. I’ve also double checked I had it wired correctly, and it is. Any thoughts? Is there something I need to add for the LCD when using PlatformIO?
Appreciate the insights.

It sure sounds like an issue with the wiring to the screen. They can be off by 180 or swapped, so there are 4 ways it can be connected.

Yup I turned all my plugs around 180°… :man_facepalming: Sometimes you just need someone to tell you that it’s wrong. Everything works now! Thanks for the help.

It’s really hard for me to say, “are you sure it isn’t the thing you just said it wasn’t?”. But no worries, I’ve been doing this long enough and it could have easily been something else.

1 Like

I am having similar issues. I can only get one motor to turn on. Tried to talk with the Repetier software and nothing happens. I tried flashing thru both Arduino and Platform, nothing. 4 days of trying and I am pretty frustrated. Where should I start.

I gave your other post it’s own topic, in case you missed it.