Controller Issues after crash

So I setup a MPCNC running on a Arduino Mega and Ramps 1.4 with DRV 8825 Drivers. It has been running very well until today when I made a careless mistake.

I was attempting to cut acrylic and right about the time I realized I should have peeled off the protective coating it was sucked up into the spindle. The machine crashed (physically), I quick hit the stop button on the LCD and stopped the spindle. I unplugged the controller, and cleaned up the mess.

When I powered back on the MPCNC acted very strange, I attempted to reset the 0 point and restart the job. The Z axis bolted up much faster then I had ever noticed before. It moved to the X and Y stops, started to move the Z down toward the touch plate, but stopped short. Then the screen kind of went blank and it started to flash.

OK reset, now every time I power on It boots properly, shows the Marlin Screen, followed by the home screen, then within a couple minutes It starts “Flashing” there is a flicker to the screen and the leds blink rapidly. After a moment and killing the power there seems to be a bit of a hot spot on the Arduino. I tried reflashing the Arduino, no change in behavior. Did I burn up something and its causing the power to “flicker”?

Oh btw I did put a voltmeter on the power supply (same PS sold here) leads to rule it out and its proving a steady 12.7 volts.

I was wondering if I fried one of the polyfuses on the ramps board

Thanks in advance


hmmm. Over working the motor shouldn’t hurt the ramps/Arduino. Over working the steppers should just skip steps. That’s not a path to destruction.

Things like it homing on it’s own are very hard to explain. The software doesn’t change like that, for anything.

Besides the flickering and the hot spot on the Arduino, are there any continuing symptoms?

If your going to go replacing parts, I’d start with the Arduino. They are the weakest link. Then maybe the drivers, just because they are the only thing that would be in the line of fire from any physical problems.

That is a odd one for sure. Unplug your lcd and try it with just Repetier. The only thing that can issue commands is the LCD and I still don’t see that happening.

Thank you guys for checking in, It is very odd. I just want to make sure its clear, once the flickering starts the screen is blank and the machine does nothing. Its almost like it is power cycling.

I am on my way to Microcenter to pick up another Arduino Mega, Wish they had the RAMPS and drivers too. But I should know tonight if the Arduino fixes the issue.



Sounds like a bad power supply, now with that description.

Moving by itself and doing odd things, = screen or mega. Not fully turning on and power cycling = power supply.

You should be able to power it via USB (I would use a wall wart type, instead of my computer, but I’m paranoid). If it’s the power supply, then Marlin would still be running and the screen. If that works, then it’s either the power supply or the arduino’s voltage regulator.

The RAMPS board is very dumb. There’s not much that would fail partially, and if anything failed, I would expect smoke. The micros are on the arduino and the drivers.

1 Like

Just a quick update, I picked up a new Arduino Mega and flashed it. It resulted in no change, Dang.

As it flickered I put a volt meter on the terminals of the RAMPS power plug and the voltage stayed steady at 12.8 volts.

Next I disconnected the power plug from the RAMPS and plugged in a USB cable (through a power brick, good advice) The board did not go into the flickering.

I want to see if I can measure the power on the RAMPS board someplace to see if the power is indeed cycling.

Next step might be to try a new supply, I do have one here but I’m not crazy about the idea of cutting the plug off.

I wish I could find a barrel plug to hook into the RAMPS plug.

I’ll update in a bit on my findings



Have you tried with no screen and just repeiter yet, pretty sure it’s that or the power supply? Lets try to eliminate things before you keep buying stuff.

You can also take off the drivers, with the screen and with just repetier to see if they are causing it.

1 Like

Ok well this is interesting, I was pretty convinced it was the power supply, but before I chopped up another supply I decided to try taking the LCD out. Disconnected the Smart adapter, hooked up repetier, and applied the power, the computer connected and I was able to move X and Y axis as normal.

I was able to Home x and y only strange thing was, when I hit x home the z moved up very fast and then it moved to home. After y home I tried moving the z axis. It is not moving right. a 1mm move is resulting in closer to a 10+mm move very fast and almost sounds like grinding. I think my next move will be to replace the z driver, actually I should just check the voltage across it first and see if the pot adjustments do anything. I hate measuring those voltages, getting my big fat fingers to hold a probe steady on the tiny pins, oh joy!

I really appreciate all the help you guys have offered, You are awesome!

Thank you


Just thought I would post an update.

I am up and running without the LCD Screen and a new driver on the Z axis. I successfully ran a job yesterday. I previously had been running the machine just off the LCD with no Computer attached. I think going forward I am going to try to setup an old PC as the controller. I have to do some looking into the compatibility of the software with the operating system on the computer. Worse case I might have to look into a Linux build. Been awhile since I’ve played with Linux, has anyone done a build for using as a controller?

I think the last thing I have to do is try the LCD back on the machine one last time, just in case it was a goofy thing with the Z driver only.

Thanks again for all the help getting me back up and running! I’ve had alot of fun with this project.


You are describing a lot of things that really shouldn’t be happening. At this point if you want to go through it one step at a time we can probably figure out what is really going on (usually simple like a missed setting), but changing so many things at each step makes in nearly impossible to help.

Your last post says, everything works without the LCD. So from that I think the LCD seems to be the problem, make sense?

So now That wither means the 5V reg isn’t giving it enough power, the screen is defective but seems to kinda work, or the gcode you loaded is bad.

From this point here is how I think we should proceed.

1- Run my crown gcode from your computer (no lcd) to verify it works flawlessly. If that is true move to step two, if not post the details.

2- Plug in the LCD, reformat the SD, make 1 folder, place my crown gcode in that folder. Run the Gcode. What happens?

He said at some point that he tried a new Arduino too though. I’m really surprised any of this happened after hitting reset.

Ryan’s got the right advice, but if you want to do a Linux controller, a raspberry pi works fine. You can use repetier, pronterface, or octopi, AFAIK.