Configuring FluidNC for Dual Endstops

I am trying to configure a YAML file for my laser engraver running FluidNC on a MKS DLC32. I have managed to get everything working except the Y homing.

I have it set up to have the Z motor acting as the Y2 motor and use the Z endstop as the Y2 endstop.

Everything moves around great. And I can home X just fine. But when I home the Y axis, it just engages the endstops but does not bounce back off and hit the endstops again slowly. It keeps them pressed and then gives an error.

I can post my YAML config here if that would be useful to anyone.

Post it i might be able to send you my lr2 fluid nc config file or read whats wrong with yours. Your dual endstops were working before you changed firmware?

From what I’m reading: you need to open your browser you will have 3 tabs: dashboard/config/ and tablet mode. Get into the configuration tab

Once there get into the firmware settings and modify the pull off setting to a value more than 1.000 on the axis you need (please be sure y0 motor and y1 motor geta a value more than 1.000 and hit save/set every time you change a setting. ) Then you have yo make your machine square and mod the pull off setting using +1.000 to the pull off value. You wont have any homing error after that

Cesar, thanks for the reply. I have attached my YAML file here for you to see. I have my pulloff at a pretty safe 5mm.

I have also confirmed all endstops work using the $limits command. X endstop triggers x, Y1 endstop triggers lowercase y, and Y2 endstop triggers uppercase Y.

Test.zip (1.0 KB)

Will take a look in a couple of hours im outside the shop for the mourning.

Aside the shifter with gpio pins used for the limit switches yours is pretty much just like mine. (Different values of course). Get your gantry to the middle and hit homing. And manually trigger both endstops manually to see if it gives you an error too

Use the command to check each Limit switch individually. And press the one is giving you issues to check if it is triggering just where you want it to be.

Here’s the link to FluidNC switches help page.

Turn off Soft limit, and lower your homing speed also

Cesar, thanks for your efforts to help me. I solved the issue by switching the pin assignments of the motors.

The assignments are now:
Motor0 -
step_pin: I2SO.3
direction_pin: I2SO.4

Motor1 -
step_pin: I2SO.5
direction_pin: I2SO.6

So apparently the motors and endstops did not match. I verified that the endstops were on the right side, so it only left me with one option which was to swap the motor assignments.

Everything now homes correctly.

1 Like

Awesome :sunglasses: