Communication issues?

Hi all,

I’ve gotten my MPCNC up and running with the preflashed rambo control board running. I made one quick test using fusion 360 and a post processor i found on here and it worked great. I tried to start a new one and I am having an issue where it starts and runs as normal but right before it makes its first plunge cut, it just stops and makes a tick sound every so often and it never advances. The gcode terminal and x,y,z corrdinates never change. The red LED light comes on and then i force the print to kill and reset it and it works fine until I restart it and it hits this part again. Would this be a communication issue or a gcode issue? I put the same exact Gcode as the design I ran last week and had the same issue with the first plunge cut.

Running Baud rate of 250000/256000 (both work okay using a mac, though they have been a little more laggy per usual)

Rambo board

repetier 1.1 and 1.2 (I tried both seeing if it was a software issue)


Im hoping this is just a gcode issue and not a firmware, but the red light that pops on when it starts faulting out scares me.


Thanks ahead for all your help!

Try running Ryan’s crown gcode. Does it run your gcode in the air, not cutting anything? It may be your gcode; can you upload it?

That was going to be my next step. The only reason I havent done that is because I ran my old gcode that worked last week and the same thing happened. Basically what I can do is set my home and everything and when I start it, it runs right where it needs to make the first plunge cut, but it just stops. I can hear the steppers droning at a higher pitch like they want to move and it’ll just run one line of gcode every minute or so and then I realized the red LED light popped on.

I have attached the Gcode I am trying to send.



Sparty.gcode (2.88 MB)

A quick scan and your gcode looks OK - the only odd item I could see is the F333.3, which is in the range of typical values, but I just haven’t seen a decimal point used for that. Try replacing the F333.3 with F333. Also, some pictures of your setup might help too. One other thought, do you have a 6A power supply connected to the Rambo?

1 Like

I do have the 6A power supply, I can snag pictures quickly. Upon looking at the previous Gcode that worked last week, that had an F code that was a whole integer, so it didnt have the decimal. So unfortunately, I dont believe it is that. I am wondering if I accidentally deleted something from my laptop when I went on a cleaning spree, which would be weird considering I kept Fusion 360 and Repetier whole. The only thing I deleted was arduino but I never had to use that before.

Well… I have no idea what I did but I just plugged it back in and everything was super responsive and its working… I wonder if it was the order I plugged things into my laptop? Will keep an eye on the issue however! I appreciate the advice.