Cncjs Error

Hi please help me!

After 2 days of searching and asking, I managed to install cncjs on the pi. But now I have drawn a square of 1000x1000mm converted to gcode with fusion 360. I can open the file in cncjs I get to see the drawing but when I press play I get an error

Error:Line Number is not Last Line Number+1, Last Line: 0
Resend: 1

And how can I set my work surface in cncjs?


What firmware? Marlin? grbl?

Are there N1 line numbers at the beggining of your gcode? Those need to be exactly sequential which makes editing manually a real pain.

Setting zero depends on firmware version. Marlin support is coming along, but not 100% yet.

The last time you helped me, you shared this link with me

The gcode made whit fusion.

;T1 D=1.587 CR=0 TAPER=90deg - ZMIN=0 - spot drill
N10 G90
N15 ;Units in mm
N20 G92 X0 Y0 Z0

N25 G1 Z5 F2000 ;T1
N30 M106
N35 G1 X140.433 Y622.468 F2000
N40 G1 Z40 F1000
N45 G1 Z0 F1000
N50 G1 X144.157 Y599.859 F2000
N55 G1 X147.84 Y577.234 F2000
N60 G1 X151.519 Y554.572 F2000
N65 G1 X153.368 Y543.222 F2000
N70 G1 X155.229 Y531.855 F2000…etz

Can you configure the post processor to not put the N10 N15, etc. in there? I don’t use fusion, but I’m sure thats your problem.

Do you have a suggestion which post processor is the best? That use now comes from the v1 site.


I just read through it, but that is still a bit too difficult for me. It’s chinese for me then that I understand.


Try Estlcam. It is way simpler. Ryan’s tutorials on it are great.

Thank you I put the lowrider to work with Estlcam, it is indeed an easier program. But now I have a new challenge. I photograph fabric patterns and I draw them in inkscape and export them as a DXF file. When I turn on the machine, he starts to make the pattern exactly to size, but he always blocks and he does not bite while drawing and he did not do that with fusion .

I’m sorry. I can’t understand what you’re saying. I got that it didn’t have this problem in fusion, but I don’t understand what the problem is.

He makes short stops during the sign. in the meantime I have tried the gcode with the sd card. with the sd card he makes a smooth movement

This is a bug in the current CNC.js version (0.9.18 or lower). It has been fixed in 0.9.19. The v1pi image will be updated soon, but I haven’t found the time yet. You should be able to update manually.

is there a manual somewhere. or is making the update a very difficult job?

Thanks for your help

If this is a v1pi image, you can stop the service using: sudo service cncjs stop

Then you can upgrade with: sudo npm install -g cncjs@latest --unsafe-perm

Then reboot, and it should start up. Be patient, it will take a while on a pi.

I am working on the new image, but some of the infrastructure has changed, so I have to work just to get back to ground zero. I hope to have the images this week though.

That would be great. where are you going to post it on the forum?

If you have an idea when it will be ready, I will keep it in sight.

Thanks again for your good work.

It will be at the tail of this post:

v0.16.0 is on github now:

I haven’t tested this on the CNC, but it’s working as well as it can on the desk.

Hello Jeff. Thank you very much I will get to work with it, I will let you know how it goes.
Is it possible to connect the pi with an ethernet cable? I still have an old desktop on which I put ubunto, but now it is not connecting. the computer is not equipped with WiFi

I still have the problem that the lowrider makes small stops with cncjs. And with the SD card he makes a smooth movement

you may try to use post processor referred on the Milling Basics page