Cannot init SD Card

This is a continuing issue with my Primo. For the history, see this topic. I replaced the Rambo board, and the “halted” problem went away. Now I have a new board, with the latest firmware. But, it has a new problem. The chances of having two bad Rambo boards in a row are extremely rare. I hope that someone might be able to help me resolve this new issue.

The problem is that when I insert an SD card, the display says “SD Init Fail”. This is the 16GB SanDisk class 4 SDHC that I purchased with the Primo kit. The card works everywhere, except for in the Primo. I have also tried another SD card that works fine in the PC, but will not work in the Primo. If I plug the card into my PC’s built-in SD card reader and use Repetier Host to read the gcode file FROM the sd card, it will cut just fine across the USB cable (proves the gcode file is fine).

I also tried a replacement display board, with exactly the same results.

I installed a real ferrite core on the power cord (no change)

I cut a slot for the ribbon cables in the Rambo case, so that they are not laying across the power cord (no change)

I temporarily unplugged all the steppers, z-home plate and only left the power and display ribbons connected. Power-cycled and… (still has the error)

Finally, I also replaced the ribbon cables (no change)

Any ideas?

Ryan had some trick for these… Putting the files in a folder, or making a folder, but you don’t have to put anything in it. Something weird like that. I can’t remember.

The sdcard is read by the screen. Did you replace the screen?

Yes, this is a replacement screen, due to this problem. When inserting the card, it immediately says “SD Init Fail”, regardless of the contents or presence of a folder. These are also new ribbon cables, and I tried to different power supplies.

Make sure the SD card is formatted to FAT32 or the reader can have problems.

I tried fat, fat32 and NTFS. So frustrating.

Do you have a smaller capacity SD card? I don’t know a lot about the Rambo boards specifically, but I work with a lot of devices that use usb/SD drives for firmware updating purposes and a lot of devices can only address smaller capacity cards.

Also, after doing some quick searching around, maybe try formatting the cards with SD FORMATTER.

Good idea @Strider_Matic . On my SKR Pro, the microSD that came with it could be read by any machine but the SKR, even after multiple reformats. I took a larger card and put a 500MB partition on it formatted to fat32 and no issues since.

I have a 512MB SD card that I formatted with FAT, and I have the 16GB SDHC (c4) that I bought with the kit, formatted with FAT32. Both worked before the Rambo replacement. Both fail to init after the rambo replacement board. Both work fine in the computer, camera and everywhere else I use them. I am travelling this weekend. I’ll try the SD formatter when I return on Sunday. Thanks for the tips.

Found this posted by “thinkyhead” on the marlin support channel to solve a similar issue to what you are having, might be worth a shot?

Try adding this to the end of the setup() function in Marlin_main.cpp

#if ENABLED(SDSUPPORT) if (!card.cardOK) card.initsd(); #endif

Where is “marlin_main.cpp”? How do I access that?

It is within the Marlin firmware folders that have to be flashed to the machine, if you are not familiar with the processes involved to alter your firmware best you talk to @jeffeb3 to talk you through the process.

Nice try, but we have docs for that :slight_smile:

You would unzip the firmware, find the file inside (probably Marlin/src/marlin_main.cpp?) And change the text inside it (using platformio or arduino ide).

We used that lcd, cables both your cards and my card here with your files and my files. You got it home and it won’t read the any cards at all?

Swap the ribbon cables one is for the power and one is for the card. Maybe something happened.
If I have a error like that in any screen I usually just have to reinsert it.

When you put it in the case maybe you folded them too tight and they are not seated well in the plug (the wire and it’s black plug, not the plug on the board)?

Def. Take it out of the case.

Okay, as weird as this is I just had one say sd init fail. I can replicate it and solve it…depends on how far you push in the card. Take out the card, let it refresh and say media removed. now stick the card back in but not all the way leave about 1/8" maybe 1/16" , media inserted? I could then screw it up by pushing it in further. I honestly have not seen this before but give it a shot.

Hey folks. I’m sorry for being silent for a few days. Priority family stuff got in the way of my CNC play-time. I truly appreciate all the great input. @vicious1, I tried ever so slowly putting the card into the slot, and it just goes from “Media Removed” to “SD INIT Fail” immediately. There’s no difference with the card hanging-out, or all the way in. You gave me some hope though :sunny:

I recorded some video of the problem. I have two cards, like I said in the post from last week. The 16GB card throws the SD INIT FAIL. But the 512MB card does not. However, if I try cutting a job from the 512MB card, the cutting tool drives all over the work and destroys the job. There’s nothing wrong with the gcode files on the card - I can cut them across the USB cable, reading the very same card from the computer, and the job cuts flawlessly.

Here is the video.

Well crud. Lets swap the card and screen.

I am wondering if something has changed in the firmware for the LCD’s I had never seen this error before in all my years dealing with these exact screens, ever. Like I said I had it happen on one of my printers. I wonder if out screen timing hack is no longer needed, or needs more. If that screen and card is extra sensitive I can test it with them.

I’ll bring the SD card, power supply, LCD and Rambo. Is tonight okay, or should I wait until this weekend? Your call.

I don’t have any more Rambo’s until the RMA’s return…I forgot to take your swap out of inventory so I had to ship my board out to cover the last order. I can swap all the rest though. I can’t do today but tomorrow of this weekend is fine.

I’ll bring the whole mess so that we can quickly test it with my card anyway. I’ll come by tomorrow after 4pm.