Cannot connect to Ramps/Arduino Mac/Linux/Windows

I purchased the kit with the “preflashed” Arduino with Marlin, along with the wiring kit. I have all 3 stepper axes connected along with the T0 resistor. I cannot get anything to communicate with the Ramps board in any operating system and multiple baud rates. I have tried Repetier Host on Mac (hard to get the mac to recognize the off brand Arduino FTDI but finally got it), Repetier says connected but all commands remain waiting and it says unknown firmware. Windows 10 recognized the board and found the driver automatically. Repetier does the exact same thing. I also tried connecting it to my 3D printer’s Raspberry Pi running Octoprint, no dice. I have no desire to use this as a 3D printer but a CNC, mainly I wanted to test the motors using these 3D printer programs. I plan to use Catia for CAM/GCode generation and a modified CNC version of Octoprint to run the CNC.

I’m all out of ideas and really sad I spent so much money on this and can’t even get the darn thing to connect. Is there any way I can verify that Marlin is indeed flashed on the Ardunio? Or can I be pointed where I can flash the correct flavor of it for this machine? I don’t figure it matters but since I purchased the kit so I wouldn’t have to fuss with this stuff I’d rather not screw it up by trying to reflash the firmware.

I suspect you’re seeing the same thing I (and a few others) have seen… and the fix is downloading and installing a proper driver. The clone Arduino Mega I’ve received in a couple of parts bundles from use a different chip than the genuine Arduino Mega’s do. It’s called a CH340g or somesuch and is a larger rectangular chip near the USB connector… versus the smaller square Atmega chips on the genuine Arduinos. Installing the correct driver should allow you to communicate with it normally. It’s documented on several sites… it saved the day for me. Here’s a couple…


Having the same issue.

Repeater says connection opened but 5 commands waiting and it just sits there never changes.
Have tried multiple USB cables and used the driver mentioned above for mac got the serial port listed but can’t get the communications going.

Have the LCD installed and can move the machine around through the menu but can not get the MAC running El Capitan communicating with it.

By the way just got the machine about a month ago. Just got parts printed and put together. Electronics are bundle from vicious site.

I had to do two things on my Mac to let Repetier control my Ramps:

Install the driver found here:


Next, using the Arduino IDE to edit the configuration.h file, search for #define BAUDRATE (cmd+F)

Set the communication speed in baud to:

#define BAUDRATE 115200

You can keep the other speed in comments, just remember this: //#define BAUDRATE 250000

Perfect! It worked. I had the driver but hadn’t changed the baud rate. After changing the baud rate problem solved. Thanks for your help.

Thank you for this. I am going to link it to the ramps page. I have had this questions a few times in the last couple of weeks. I know nothing about the newer Mac’s.

Just to add a little to the post. I am completely green on Arduino and CNC so I found this information in chunks about the driver and the baud rate. In an attempt to change the baud rate I bricked my Arduino by replacing all the programming with just the baud rate code. Found the preconfigured code on this link and changed the Configuration.h file as mentioned above. First thing you must do is install the driver or Arduino IDE won’t see your board. As a newbie to Arduino my steps to fix were as follows:

  1. Download the preconfigured Marlin firmware from the link above. Along with the u8glib library if using LCD.
  2. Unzip and then open in Arduino IDE software
  3. Change the baud rate setting in Configuration.h as mentioned above
  4. Verify code
  5. Upload the new code to the board

Maybe there is an easier way someone can post. But this would have saved me a few hours of troubleshooting hopefully it will help someone else out.

1 Like

This didn’t work for me. It will not let me verify for some reason…I am all hooked up and changed the BUADRATE after successfully installing the driver.

What errors does it give at the bottom of the screen?

Arduino: 1.6.9 (Mac OS X), Board: “Arduino/Genuino Mega or Mega 2560, ATmega2560 (Mega 2560)”

/Users/Patrick/Downloads/B16_32_fullG-112515/B16_32_fullG-112515.ino:44:101: fatal error: U8glib.h: No such file or directory
#include <U8glib.h> // library for graphics LCD by Oli Kraus (
compilation terminated.
exit status 1
Error compiling for board Arduino/Genuino Mega or Mega 2560.

This report would have more information with
“Show verbose output during compilation”
option enabled in File -> Preferences.

Are you using the LCD?

Not currently but I would like to.

I added that to the library, here is the new error code…

Arduino: 1.6.9 (Mac OS X), Board: “Arduino/Genuino Mega or Mega 2560, ATmega2560 (Mega 2560)”

sketch/u8glib-master/sys/arm/lpc1114/common/startup_lpc11xx.S: Assembler messages:
sketch/u8glib-master/sys/arm/lpc1114/common/startup_lpc11xx.S:32: Error: unknown pseudo-op: `.syntax’
Known MCU names:
avr1 avr2 avr25 avr3 avr31 avr35 avr4 avr5 avr51 avr6 avrxmega1
avrxmega2 avrxmega3 avrxmega4 avrxmega5 avrxmega6 avrxmega7 at90s1200
attiny11 attiny12 attiny15 attiny28 at90s2313 at90s2323 at90s2333
at90s2343 attiny22 attiny26 at90s4414 at90s4433 at90s4434 at90s8515
at90c8534 at90s8535 ata5272 attiny13 attiny13a attiny2313 attiny2313a
attiny24 attiny24a attiny4313 attiny44 attiny44a attiny84 attiny84a
attiny25 attiny45 attiny85 attiny261 attiny261a attiny461 attiny461a
attiny861 attiny861a attiny87 attiny43u attiny48 attiny88 attiny828
at86rf401 at43usb355 at76c711 atmega103 at43usb320 attiny167 at90usb82
at90usb162 ata5505 atmega8u2 atmega16u2 atmega32u2 attiny1634 atmega8
ata6289 atmega8a ata6285 ata6286 atmega48 atmega48a atmega48pa atmega48p
atmega88 atmega88a atmega88p atmega88pa atmega8515 atmega8535 atmega8hva
at90pwm1 at90pwm2 at90pwm2b at90pwm3 at90pwm3b at90pwm81 at90pwm161
ata5790 ata5795 atmega16 atmega16a atmega161 atmega162 atmega163
atmega164a atmega164p atmega164pa atmega165 atmega165a atmega165p
atmega165pa atmega168 atmega168a atmega168p atmega168pa atmega169
atmega169a atmega169p atmega169pa atmega32 atmega32a atmega323
atmega324a atmega324p atmega324pa atmega325 atmega325a atmega325p
atmega325pa atmega3250 atmega3250a atmega3250p atmega3250pa atmega328
atmega328p atmega329 atmega329a atmega329p atmega329pa atmega3290
atmega3290a atmega3290p atmega3290pa atmega406 atmega64rfr2
atmega644rfr2 atmega64 atmega64a atmega640 atmega644 atmega644a
atmega644p atmega644pa atmega645 atmega645a atmega645p atmega649
atmega649a atmega649p atmega6450 atmega6450a atmega6450p atmega6490
atmega6490a atmega6490p atmega64rfr2 atmega644rfr2 atmega16hva
atmega16hva2 atmega16hvb atmega16hvbrevb atmega32hvb atmega32hvbrevb
atmega64hve at90can32 at90can64 at90pwm161 at90pwm216 at90pwm316
atmega32c1 atmega64c1 atmega16m1 atmega32m1 atmega64m1 atmega16u4
atmega32u4 atmega32u6 at90usb646 at90usb647 at90scr100 at94k m3000
atmega128 atmega128a atmega1280 atmega1281 atmega1284 atmega1284p
atmega128rfa1 atmega128rfr2 atmega1284rfr2 at90can128 at90usb1286
at90usb1287 atmega2560 atmega2561 atmega256rfr2 atmega2564rfr2
atxmega16a4 atxmega16a4u atxmega16c4 atxmega16d4 atxmega32a4
atxmega32a4u atxmega32c4 atxmega32d4 atxmega32e5 atxmega16e5 atxmega8e5
atxmega32x1 atxmega64a3 atxmega64a3u atxmega64a4u atxmega64b1
atxmega64b3 atxmega64c3 atxmega64d3 atxmega64d4 atxmega64a1 atxmega64a1u
atxmega128a3 atxmega128a3u atxmega128b1 atxmega128b3 atxmega128c3
atxmega128d3 atxmega128d4 atxmega192a3 atxmega192a3u atxmega192c3
atxmega192d3 atxmega256a3 atxmega256a3u atxmega256a3b atxmega256a3bu
atxmega256c3 atxmega256d3 atxmega384c3 atxmega384d3 atxmega128a1
atxmega128a1u atxmega128a4u
sketch/u8glib-master/sys/arm/lpc1114/common/startup_lpc11xx.S:33: Fatal error: unknown MCU: armv6

exit status 1
Error compiling for board Arduino/Genuino Mega or Mega 2560.

This report would have more information with
“Show verbose output during compilation”
option enabled in File -> Preferences.

Did you include the library in the Arduino software Under Sketch->Include Library->U8glib

Still not working on my Macbook Pro. Tried installing driver again, using the non-LCD and LCD versions. It verifies correctly but does not upload and will not connect. Anyone able to assist?

Error codes now…

Arduino: 1.6.9 (Mac OS X), Board: “Arduino/Genuino Mega or Mega 2560, ATmega2560 (Mega 2560)”

Sketch uses 102,448 bytes (40%) of program storage space. Maximum is 253,952 bytes.
Global variables use 4,224 bytes (51%) of dynamic memory, leaving 3,968 bytes for local variables. Maximum is 8,192 bytes.
avrdude: ser_open(): can’t open device “/dev/cu.usbmodem1421”: No such file or directory
ioctl(“TIOCMGET”): Inappropriate ioctl for device
ioctl(“TIOCMGET”): Inappropriate ioctl for device
avrdude: ser_send(): write error: Bad file descriptor
Problem uploading to board. See for suggestions.

This report would have more information with
“Show verbose output during compilation”
option enabled in File -> Preferences.

I was finally able to get it uploaded. I had to change the ports and enter a line into the terminal for El Capitan. I will do a video on this as this took way too long!

1 Like

A video would be cool! Macs for some reason are just never the same with this kind of stuff, such a bummer.

To avoid the compilation error referring u8g.h file, just comment out (//) the includes like this:

//#include <utility/u8g.h>

in dogm_font_data_marlin.h file from marlin. Take care that there is included twice in the same file (up arround line 14 and in line 174)

Doesn’t that knock out the ability to use the screen? The older version of arduino works perfectly without firmware edits.

The lcd screen works great. Just install U8glib from arduino Library Manager, comment out those 2 lines, and it compiles (at least in arduino ide 1.6.9).

I am using MAC OS Mojave and can’t get my laptop to interface with the “preflashed” Arduino with Marlin. I am new to this process and a little overwhelmed. Any help is greatly appreciated.