Can not get VREF set, already replaced drivers and RAMPS

I’ve tried and tried to solve this. I’ve been trying to set the VREF with no luck and it’s really frustrating because my associates is in electrical technology.

So I connect my multimeter to 12v ground and measure VREF at the top of the pot. It reads 0 for almost the whole rotation of the pot except for a small spot thats in the .600-.650 range. My first set of DRV8825s did the same but only read into the .400 range.

I researched and researched and thought it was just a bad RAMPS board so i replaced it and went ahead and ordered a brand new set of DRV8825s. They look like the the kit ones for sale on here.

With the first set of RAMPS/Drivers I also set the Z axis one to around .420 and tried to use the controller to move the Z and it didn’t move at all.

Picture of the board with only one driver on.

Please help me figure this out. I want to get this thing running.

  1. Did you buy everything from here?
    Bought some stuff from you but none of the electronics.

  2. Are you using end stops?
    No end stops yet

  3. Are you using all my recommended parts?
    Yep using everything you recommended

Well shit. Looks like the power wires are on the wrong side. When I saw the picture where you wire for an extruder i saw the wires going into the left side and then getting jumped into the right side. Trying to switch sides now.

Yep. That fixed it. I’ll keep this up incase anyone does the same shit.