Good morning all,
I just finished my cnc mp with ramps1.4 in dualendstop.
I have cambam in software. Do you have a post processor for marlin? or which one to use?
thanks in advance
(ps: thanks google translation)

1 Like

I took a quick look at the CamBam documentation, and didn’t see anything obvious. It may very well work out of the box. Marlin doesn’t handle some of the canned sequences, but it should be OK with most of the “generic” gcodes.

The default CAM software around here is EstlCAM, with Fusion360+Guffy’s PP coming in second. For the best support around here, I’d use EstlCAM, and if you find good success with it, consider paying to remove the increasingly annoying nag screen (it takes longer and longer to save a file, but otherwise, the free version is the paid version). The general consensus is that, unless you already use Fusion360 in your workflow, it can over-complicate things out of the gate. Everything you learn in EstlCAM applies to Fusion360 (or CamBam, or any other CAM software).

Translation: I don’t know CamBam; CamBam isn’t really talked about around here; there are some alternatives that the community can help you with; hopefully someone with more/better info will be along shortly… :slight_smile:

I use CamBam and it does not require a post-processor to create g-code for the MPCNC or Low Raider.
I really like CB and their forum has a lot of good information including very useful plugins

1 Like

Thank you for your answers.
I will try again, I will keep you posted.
Jdgreen do you use grbl or marlin?

hello, after test works perfectly with the post processor by Default.
Just rename the .nc file to .gcode.

1 Like

I have run into an end with EstleCAM - I use AutoCAD 2014 - which I own - so I’m not about to upgrade just yet - and won’t if I can avoid it - I’m not designing the newest in structural architecture - so new bells and whistles don’t concern me. I’m just a simple house plan type and 2d drawing type. So with this, EstlCAM isn’t reading my DXF files coming from my CAD - I’ve played with the lines, layers types, exploding, etc. Nothing seems to work to get a circular file to load and get CAM’d up and ready to cut. Hmm…
So I am wondering if I have overstayed my welcome to EstlCAM for not buying the license yet and it is being stubborn. So I am hunting for the next CAm program - I think I’ll give this a go as I read the documentation on their site and it does look good and promising - also, not too expensive once things get rolling!
@thejat - you might want to look into this one, if you’re still on the hunt…
@vicious1 - I do like EstleCAM - I’m just getting frustrated in going from computer to computer trying other ways to troubleshoot the problems. I’ve got all the CAD CAM and other supporting software’s on two computers as back up reasons.

What are you DXF format options when you save/export?

That is the preferred file type and should be no issue for estlcam. I just double-checked and the AutoCAD r2013 works as expected.

I have had issues in estlcam with some dxfs. I remember having trouble if the important stuff is in a layer. I remember a dialog in estlcam to adjust which layers it shows. But I also have imported it into librecad and exploded everything and flattened all the layers down to one.

If you’re moving, you might try freecad. It is the same price as your 2014 autocad (free to you) and is getting modern updates. There are some people who use it for cam too.

You are right I have mine set to 1 layer.

Took me a minute to get back to this thread. I have a different issue blocking my wrk now - a computer epic fail, nothing to do with EstlCAM or such - and I am forced to move ahead with the other CAD ideas. I’m trying to see if F360 will work since I have a baseline of education with AutoDesk at the moment. I haven’t given up on FreeCAD yet - I’ll have a look at this soon I’m sure.
I’ll have another go at the DXF in AutoCAD r2013 - I thought I had used this. It might be that I need to dive into the drawing further and explode/explode/explode/etc a while until all parts have been separated.