Beginner question (electrical config)

Have built the table, put together the machine, got power to the Mini Rambo but can’t for the life of me find any document that sort of tells a three year old what to do next. ie a bouncing ball for idiots sort of set of instructions on getting the thing moving?

I tried to power it up and see if I could get only the X axis to move figuring that was safe but all I get is little cricket noise out of the lcd controller.

Am I missing some major point?

Do I have to download something? plug it into a computer or something…?



Did you get the rambo from Ryan?

The screen isn’t on in the photos. Did you see it come on and show something (not blank)? It may be that the lcd is plugged in backwards. There are 4 ways to hook it up, and only one works. Luckily, the other three don’t hurt anything.

Yes, got everything from him.

When you say 4 ways, ie just keep swapping them until it works?

The plugs may need to be rotated. They are keyed, and sometimes keyed wrong. You can pull on the plastic shroud on the board and it will come off, then plug it in the other way.

If the way you have them is A, and rotated is B, and you have them in position 1, but you could swap them to make them B, then 1A, 1B, 2A, 2B.

Just to confirm, you haven’t seen the screen show information?

1 Like

Ok, will rotate the plugs in order and see how I go.

All I got was a very pale flash of the LCD in time with the chirpchirp sound

Will do it now and report back.


Worked straight up mate. Great.

Then plugged the X axis one into the board but don’t think it has registered it.

So from here is there some sort of set of instructions /document on how to get the whole thing up to speed?

  1. Don’t connect or disconnect the motors while it is powered up. That is dangerous for the drivers.

  2. The '?'s are just because it hasn’t been told the origin yet. It doesn’t know if a motor is connected.

  3. The resetting on a twist of the knob still indicates something wrong with the LCD. Either a wire is crossed, or I have seen some reports of it being screwed together too tightly and it shorts something. When you get that fixed, you’ll see that there aren’t many choices in thar menu, and they should mostly make sense.

  4. The instructions don’t hold your hand. The stuff Ryan has written are all at We recently moved then over to that format hoping people would volunteer some changes, but that hasn’t happened. At some point, I doubt there will ever be super explicit instructions. You wouldn’t find explicit instructions for a computer. It just has too many options on how to use it.

I am thinking a simple LCD page would really help though. It would have been good for you to have an example of what it should look like, and where it didn’t do what it expected.

1 Like

thanks mate, got it to go.

Will just work my way through it.

I really appreciate your tips/advice.


1 Like

the plug was back to front as you suggested.


I would say start here, and follow it to the basic instructions linked at the bottom.

That will get you a crown and from there, you will probably have more specific questions. You are in good hands, we will get you up and running.

Thanks for that. I got childishly excited when it started moving yesterday.

Such fun.



Next problem.

When I plug it into the board and fire up the power I am getting some Windows messages that sort of say that it can’t connect. I have here a video of that. I am not a Windows 10 man I am afraid.

I do wonder if there is some sort of coms port issue? I remember at work having some old mate dial in and ? reassign usb ports to coms ports or vice versa? Is this sort of what is happening?

Anyway have a look at this and see if you can shed some light on it for me.
Sorry to be demanding.


I think that usb cable might be bad or try a different USB port. Did you install arduino IDE and it’s drivers?

My standard troubleshooting question for unable to connect: “Is Repetier-Server installed?”

1 Like

Have deleted Repetier server and rebooted.
Have installed the drivers

Still no good.

will go and get a new cable
will report back.


@vicious1 Are there any flashinblinkenlitzens on the mini-Rambo that would indicate power on, or any other status? @Robertblackburn Have fuses been checked?

Just some general info here. There is a USB to Serial chip. This chip is powered by the USB cable. If it is powered, and you have a good USB cable, then Windows should see it as a device, and you should be able to send data.

The microcontroller on the mini rambo needs 12V power. If that isn’t powered, then the data sent by the USB to Serial chip will go nowhere. Both need to be working correctly for Repetier Host to connect to the microcontroller and the get right messages to think it is connected.

I don’t use windows, but I am pretty sure that the problems you’re seeing are with connecting to the USB to Serial chip, not with the micro controller. So I’m with Ryan, that it is hopefully a USB cable, or maybe your USB host on the computer can’t provide enough power for the little USB to Serial chip.

OK. Thanks again.
It was the usb cable. Have replaced it with a slightly rusty one from a mate over the road and it works fine now.
Clicked connect and the software straight away came to life.

So shall have a read of what to do next. I do notice that as soon as I ask it to move any axis it winds the Z axis down about 10mm then sends the X axis heading off towards the side of the table. Have hit emergency stop.

All sound OK?


1 Like

Have to go to work but loaded the crown and it is going but very very very slowly.

So will trouble shoot this tonight.

(couple of hints whilst I am away would be good…)

Thanks for your help


Is it Ryan’s gcode or your own?

Very very slow usually means you missed a setting in milling basics. Probably the gcode units.

If it is Ryan’s gcode, then, what controller do you have and what firmware?

1 Like