Autostart not working

I want to start and run my gcode from my sd card on startup using sd ramps. I’m not sure what I’m missing. I thought if you named the file Auto0.g it would automatically run it. I tried to comment out the Sd_menu_confirm_start, but obviously that only took away the confirm run screen if I had my lcd hooked up.
It also won’t work using my lcd screen either, but will run if I start the program in the menu with my lcd or repetier host.
Ramps 1.4 running Marlin.

I have never tried it. It probably wouldn’t hurt to enable the one under that, to add it to the menu. I have a sneaky suspicion that the issue is the capital A in auto.

I made sure it was auto0.g
Also tried

I would be tempted to poke through the code. Or open an issue with Marlin. Maybe the way it works changed.

I searched around a bit and found this bit of unconfirmed information:

If you have defined SD_MENU_CONFIRM_START
you must press a button on the LCD in order to start printing. If you have no LCD this code will never be reached.

I see from your image that you do have this define enabled.

1 Like

I did try it with the confirm disabled last night. It did not help. Just now if your using the lcd, and start a print in the menu, it doesn’t have the confirm step before the program starts.

I have a Rambo with LCD 12864 display. I just put an auto0.g file on my SD card and put in my machine. It worked. This is the “stock” firmware from V1, so there are no obvious changes that need to be made in the firmware. I also looked at the autostart code. It was pretty straight forward. The one things that gave me pause is in pins_RAMPS.h there is this define:


The value of this pin changes based on the display. You are not plugging your SD card reader into the same pins that are used for the REPRAPWORLD_GRAPHICAL_LCD (the V1 default) on the Ramps board, so perhaps you need to change the value of this define to match where you are plugging in your SD card reader. I think this is a bit of a reach since you are able to start SD files from Repetier-Host, but I thought I’d mention it anyway.

1 Like

I gave up on that. I changed over to a low frequency plasma cutter. I wish i would of had time to follow through on it. New baby and other projects got in the way. Thanks for the suggestions.