Aspire Marlin-mm test 5

Afternoon all :slight_smile:
Can anyone tell me how to ajust steps in this post processer (marlin mm test 5 ) this works perfect except the steps are wrong :frowning: , ive set the steps on marlin mode and when jogging the Lowrider via marlin mode thay are exact ,
When i run toolpath on my strut brace (1004 mm ) and cut via sd card my cut comes out 35mm too short :frowning: can anyone help ?
Thanks in advance

The post processor doesn’t do this. (well it could but it would be a factor of 25.4 off).

This has to do with your design getting imported to your CAM and that conversion or scaling ration. Thinking pixels to mm instead of mm to mm. Maybe.

Export your vector in mm or inches instead of pixels.

1 Like

The part im referring too is the strut brace download directly from ryans v1 site , ive also tryed to cut the same file in carveco make and cuts to the right size :confused:

When you import the DXF into your program verify the size before you cut it. That can be done with a measuring tool or setting the background grid depending on your program.

The Post processor just translates the coordinates into a language the CNC can read it does not scale anything. The problem is in the CAD for sure (You verified the file in another program). I can’t help to much since you are not using any of the software I have.

1 Like

OK, just a quick thought.
Ryan’s designs are made in “MM”.

Is the Aspire project designed in “IN”?

I have seen that happen in a few CAD/CAM packages, the translation of the increments can be skewed through the PostP.

1 Like

That is done in CAM. The Post processor HAS to output in mm/min which has hard-coded and has no relation to your design size. The PP does nothing to resize a design. The CAM program outputs coordinates not the PP.

1 Like

this would make it 25.4x off.

This is .96x off. It doesn’t really make sense. Unless it is a pixel to mm thing like we used to see with old inkscape versions.

1 Like

It was just a thought. Seen a lot of software measurement weirdness in 28 years in the printing industry, even computer to computer.

No sure but ive cut a basic square from aspire and that perfect, using marlin test 5 :slight_smile: so maybe your proberly roght ryan woth your old Inkscape theory,
Another problem solved:)
I must add what a amazing product and community u have built ryan im just gobsmacked its all free :slight_smile:
Your efforts and work ability is well worth paying for :slight_smile:

Thanks again


Did you just import the DXF into Aspire? Or was there some other software in between?

1 Like

Yeah the software toolchain can be a pain but once you get it right you will not make that same mistake twice.

For some reason, I remember David finding a crazy issue. At some point Inkscape change from a pixel count of 93 to 95 per mm or something like that. It caused issues for a while until he found it.

1 Like

Can you share a screenshot of your screen when you “Save Toolpaths” showing the post processor section?

Also, a screenshot of your “Material Datum” screen aka “Job Setup”

I just want to compare something.