Another problem

Just when I think I’m finally good to go something else happens. I rebuilt my router table and got it as close to level as possible.Then I installed my surfacing bit and for some reason it is not responding to home my z axis. I thought at first maybe I had a bad connection on my touch plate wiring but I checked continuity and it was all good. Then I tried it with the touch plate code:

G28 Z
G92 Z0.5
G0 Z5 F480

and it worked correctly. Then I loaded my surfacing gcode and added this gcode to zero all axis, but it didn’t stop when I hit the touch plate. This code has been working fine on my other cuts:

G91 ; Relative positioning, just in case
G92 X0 Y0 Z0 ; Set Current position to 0, all axes
G00 Z5.0000 F500 ; Raise Z 5mm at 8.3mm/s to clear clamps and screws
G28 X Y Z ; Home in order, w/zprobe
G92 Z0.5 ; Account for probe thickness (set your thickness)
G00 Z5.000 F500 ; Raise Z probe off of surface
M00 ; pause for LCD button press
M03 S<s> ; PID, set spindle speed
G90 ; Absolute positioning, just in case

One other thing. This gcode doesn’t sound a ding like the other gcode does when it starts down.

Do you have a way to check M119? Do you have an attached computer? I would check that it is triggered 5/5 times while touching it with the plate. Maybe the bit is somehow insulated? Maybe it has some grime or sealant on it?

I don’t think that <s> is supposed to be in there. That should be a number.

As for the different sound. The feedrate is a little different (480 vs 500) and it is homing X and Y in the same line. Of you have a connected computer, you can try sending each line one at a time and observing what seems different.

1 Like

Agreed. Last time mine didn’t stop my collet had too much crud in it. And that M3 line is not needed at all.

I copied that text from the Milling Basics page and didn’t change anything. I tried cleaning my surfacing bit and its working now. Maybe that was the problem. However, its not doing what I expected it to do. In Estlcam I chose Hole and Pocket. My surfacing bit is 1" wide but its only moving over maybe 1mm at a time with each pass. How do I get it to move over almost the width of my surfacing bit?

That M3 is there because some of us used to use a speed controller, best to take it out.

Click on the wrench icon for your end mill and check the step over. 1" is huge so take it shallow or a low step over. You build is going to need to be extremely in tram to get no scalloping/steps with that.

Side not make sure your spoilboard is above the surface and you can surface off all the edges or you will end up with a actual pocket and only material smaller than the pocket will ever be level in your build. Most of us don’t need to surface our builds because Z depth is rarely critical. When it is for something like a fancy vcarved sign you just surface your work material and go from there. I guess what I am getting at is surfacing can cause more issues than it solves if you are not careful. That is why it is not in the instructions anywhere.

1 Like

I set the step over at 50% and that was probably too much but the DW660 seemed to handle it ok. I tried to adjust the tram by loosening some screws and tightening others but it wasn’t enough. I’m still getting a little stepping but not as much as before. I don’t have a tool see how far its off and I don’t know how else to adjust it with the MPCNC. There aren’t any adjustment screws for tramming. Maybe a little sanding will help with the steps.


I made a simple tramming tool. Printables It does not need to be fancy.

On the MPCNC the easiest way to tram it is shims or spacers on the inner side of the clamp. With that said a 1" bit is going to require a super extremely tram router to get perfectly smooth. It is not going to be easy. I would say a 1/2" is a big as most would typically go.

I used a Sheet Sander and got it pretty smooth. I’ll see if it works. I’ve got one other little issue. I ordered a 12v 40mm X 40mm brushless fan, Order #20572, August 31, 2022, and its starting to squeal like its going to fail pretty soon. I don’t know if there’s a warranty on it. If there is, I just broke my only 1/16 double flute bit and I have to order a couple more. If they will give me a replacement on the fan I would like to include it in the same shippment. I manually drilled a hold with the flute bit and forgot to pull it out before I moved the router. !$&!#*!!!


That kinda invalidates the point of surfacing. Next time just knock off the high spots and leave the rest. You might have made a giant shallow spot now.

Are you using it with 12v? I don’t mind replacing it once, but I use the fans 24/7 and I am pretty sure most of mine are all over a year old if not 2-3 at this point. If you are using 12V, not more I will replace it. Place the new order and drop me an email with the new order number.

Yeah, it did but its way bigger than anything I’m going to cut. I just wired the fan into the power terminals on the Rambo v1.4 board which are 12v. It squeals when it first starts up and I have to thump it a few times to get it to stop.

I just ordered the new bits. Order #20969

On its way.

Might want to try and get the fan away from dust a bit more, or some sort of filter.

I’ll do that. I just screwed up royally. Forgot to remove the Touchplate clip before I started my router, jerked the plate and the clip off. I saw the general direction they flew but my garage is kind of a junk yard. I moved all kinds of stuff looking for them and finally found the clip on a shelf. I just about gave up looking for the plate but then discovered it still was on the router table under some stuff. Ever done that?

That is why they come with the magnets. I left it clipped on one time. Since then I have only ever used the magnet.

1 Like

Magnets? Explain.

1 Like

I looked through the box of parts my MPCNC came with and I didn’t see any magnets.

The tiny touch plate kit includes a small cylindrical magnet. Mine was stuck to the clip inside my kit when it shipped. I super-glued the magnet inside the clip so the clip will make electrical contact to the collet without needing to be physically clamped to it.

(Crossing my fingers) So far I’ve not started the spindle with the clip still on it, but if I do someday, I expect it will get “thrown free” pretty quickly rather than the touch plate wire getting wrapped around the collet or experiencing some other dangerous and damaging failure mode.

1 Like

Yeah, I’m fortunate that clip didn’t hit me, it came really close. It actually broke the wire a couple of inches from the clip rather than pulling it out.

The first few touchplate kits did not come with a magnet, but it is very small less than 1/8" diameter and probably 1/4" long.