An Aensuslm Laser Mount & a few Lightburn setup questions

I decided to give that Aenbuslm 80W (10 watt output) With Onboard Air Assist Laser a try on my newly finished MPCNC. They’ve been selling them on Aliexpress and Amazon for a little while. Not sure how well it’ll work, for less than $200 I’m not going to be overly surprised if it’s less than amazing.

image

I made a tool mount for it if anyone is interested, let me know and I’ll post on Google docs for download. I think I’m going to shorten the “standoff” distance from the z axis a bit so I lose less table space.

Now I have to figure out why a can’t get Lightburn to control my laser. A couple quick questions if anyone has some insight…

  1. Should I be connecting my USB cable from my laptop to the SKR board or to the TFT? So far I tried the SKR connection and I can’t get control. I tried setting up a new Marlin device on COM4 with no luck. (I would’ve kept trying last night but my Missus was getting irritated!)

  2. Just for my curiosity, is there a way to fire the laser from the TFT interface the way that you can from the Lightburn Move Tab like I can on my prebuilt Sculpfun S9? I use that regularly in Lightburn to get pieces positioned. It’s be nice to be able to do that in the event that I’m bringing .gcode to the MPCNC on an SD card.

Hi Dusty,

I have purchased the same laser and have it mounted on my LR3. Have you had any luck with getting the laser to work?

I have been able to get mine to fire but only via SD card in the TFT. The results looked to be promising with cutting through 3mm black acrylic but only for square test pieces, 20mm, 30mm and 40mm. When i introduce curves or circle the laser looks to be miss firing. Still trying to work it all out.

I did have the SKR Pro v1.1 connected via comport and the lightburn software identified it as a GRBL machine but it did not work 100%. It would frame the cut area [where the laser is driver around the area and not firing] but would not respond to any movement for setting up position. But when i hit go it would complete the whole job but not fire the laser.

I am now sorting out a separate PSU for running the laser and the little air pump once I get some more connectors as i don’t want to destroy the y-piece supplied in case someone has the solution :crossed_fingers:

look forward to hearing how its all going.

Hi Sam,

Are you actually running GRBL firmware on your SKR board? Mine did the same thing at first. Lightburn recognized it as a GRBL driven machine when it was actually a Marlin driven board and it ran the laser and CNC erratically.

I found the solution on Lightburn’s forum. Simply launch Repetier Host first and hit connect. Then close out Repetier Host and launch Lightburn. After doing this the glitches went away.

This is where I found the answer (only difference is he used Pronterface instead Repetier Host but they both work):

Lastly, here’s a link to thread where Robert Bunney gave me some great help. (He’s like the laser whisperer!)

Hope this helps!

1 Like