A little confused with wiring steppers in series

I bought 10 of these cables:


And I’m using this image as a guide:


I’m guessing my color/pinout is:

1 = black, 2 = green, A = blue, B = red.


This is what I have for coil 1 and 2.


I’m confused about the other connections. Does everything else that isn’t connected just get matched up to it’s color. Example: Coil 1 Ramps pin 2 (green) connects to stepper 1 - pin 2 (green)? Then Ramps pin A (blue) connects to Stepper 1 and 2 pin 3 (blue)?

Your diagram should be correct…but that is for each side. Every stepper needs all 4 connections. The diagram is split up for clarity. I do sell pre-made wires.

Really regret not buying a harness among other pieces from you. I made an ugly splitter and now both steppers on each axis move when I tell them to, but it’s not smooth. It’s jerky and jittery. I’ve adjusted my drivers [A4988] from around 640 to 560 for my 1.4amp limited steppers. I also edited the config to cut the steps down in half. Is there anything else I’m missing, or is this just bad wiring?

Edit: I tried plugging a single wire directly into a motor and it jitters without spinning.

Bad wiring. You probably got one of the coils backwards.

Hey, Barry. Thanks for the reply. I tried connecting a single stepper to the X axis on my Ramps board using a single unmodified wire. It behaves the same as the steppers on the wire harness I created. No chance that this could be a result of one of these settings in marlin?:

#define DEFAULT_AXIS_STEPS_PER_UNIT { 100, 100, 400, 100 } //MPCNC


#define DEFAULT_MAX_ACCELERATION { 500, 500, 35, 10000 } //MPCNC


Using all three jumpers?

What gcode are you issuing to test it?

Yup, all three jumpers. I was just moving the X axis a few mm at a time using the interface on the Ramps board. Now I installed repetierhost on a laptop and connected it to my ramps via usb and tried moving it that way and still, same result. Jittery steppers.

You have a stepper directly connected to the board, no funky wiring, all three jumpers, using repetier host, steps cut in half in the firmware and flashed successfully.

The only thing left is to test each stepper, in each of the ports. Powering off between moving them. If that doesn’t work, Something has to be faulty or one of the above steps isn’t correct. Are you sure you have 1.8 degree steppers? The ramps is correctly powered? A few pictures are worth a million guesses.


Yes, 1.8 degree steppers. 12V 5amp power supply.

I just read the comments on this wire in Amazon. They said they had to swap the middle two wires. I tried that and now it works.


Thanks for helping me troubleshoot this.

Dang, that is a weird first. Glad you figured it out.

Took a second look at the first image and the wiring is really not right. Good catch, I’ll have to watch for that next time I need a wiring harness.