1/8th turn play/lash in Y1 stepper

Hi. I’m running the STEPPERONLINE 17HS19-2004S1 motors and I’ve just noticed the Y1 stepper has a lot of play. I can easily move the rail by hand and watch the shaft spin about 1/8 of a turn. When it hits the end of the 1/8th turn in either direction, it feels very solid. Is this normal?

If i send a move 50mm command I can flop it back and forth the whole way. When its actually cutting it feels pretty stable.

I tried swapping x1 and y1 stepper drivers which made no difference.

I tried swapping y1 and y2 plugs which also made no difference.

Should I be looking at a replacement stepper or something in firmware? perhaps even swap Y1 stepper with Z?

Im running the skr pro 1.2 with v1e marlin v2.1.2 I believe it is.

The reason I ask is because I’m suffering a lot of missed steps trying to cut a piece of pine even as shallow as 2mm. 3mm is out of the question. I am running a black 6 flute 3mm endmill. It didn’t used to be black it just uhh… turned black shall we say. So that probably doesn’t help but I broke my 1 and only single flute endmill on the weekend so I have another month or 3 till the next lot arrives.

correction marlin v2.1.1* the latest v1 maintained marlin

Make sure your grub screws are tight on the stepper shaft. Sounds like they are loose as there should be no play like that. :thinking:


Oh man it’s so simple and you’re absolutely right. I think this was even mentioned somewhere in the build docs. Thanks Matt!

1 Like

50% of the time it’s the grub screws all of the time.

1 Like


1 Like

Ah so true, it gets us all at some point.