Z1 motor powers down in mid cut and loss of speed movement

Hello, as previously mentioned in this topic https://forum.v1e.com/t/machine-changes-movement-speed-to-faster-or-slowly-on-each-poweroff-on/42851, my machine starts with a slowly movement on all axis and I have to poweroff/on to get it back to its normal speed.

I decided to create a different post because the previous one had different problems I had pointed and some of them were solved. However, the machine slow speed on startup did not solve.

In addition, I think there is a related problem. During a cut, one of my motors (Z1) suddenly stops working. I observed this problem in a drill helical hole, and it happens several times if i restart the job and try it again.

Additionally, i also observed that if I home my Z axis, and then my Y axis, The Z1 motor stops working. I have to power the machine down, and power it on, so it goes back working. Afterwards, if I start a cut, in the middle of it the Z1 motor stops working as I said before.

I have checked the wirings, it seems ok. What I see strage is the fact that when powering off and on, the motor goes back in working, but seems to do only for a few minutes.

It is a Lowrider 3, I’m using a 12V 6A power supply, MKS GEN L with endstops, Spindle has 1hp, and I’m using Estlcam.

Thank you in advance.

clarification, you’re using Estlcam only for generating the .gcode, or are you also using it as your controller?

Wiring: is this a jackpot board?
Wiring: When I’ve had ‘slow motion’, it’s usually because my end stops are plugged into the wrong port, or the end stop wiring is not correct.

Hello @williamaadams , I’m using Estlcam to generate gcode and Pronterface to control the CNC. It is a MKS Gen L v2.1 board.

I believe the wiring is ok, because the strange part is that the slow movement is gone when I turn off and on the machine. Also, I checked them with m119 and they trigger as supposed to.

So curiosity question,

If the same gcode is is loaded and run from the SD card, same results?

Currentely I cant test that because my board do not have access to SD cards. I’m only able to print plugged into the USB.

Nonetheless, the Z1 powering off also happens when the CNC is not cutting.

My apologies, I was wrong for assuming they all had a SD slot.

So some questions:

  • When the machine moves slowly, does ot move the correct distance? If you command it to move 100mm in Pronterface, does it move the full 100mm? (Is steps/mm the problem?)

  • Does resetting the board reliably fix the problem? Does it reset and work properly every time, or do you have to reaet it and it has some percentage chance of being OK.

  • Does it ever start moving slowly in the middle of a job?

  • Does it always go slowly if you do slmething specific? Is it always at the end of a job?

Personally, I don’t like having computers in the machine room, so I would always want an SD card reader available. The 12864 controllers are cheap, and I’d recommend it, but of course it’s your setup, so it has to work for you.

The Z1 motor powering down really sounds like a wiring issue to me. I would want to triple check all of the wire connections to that motor. You can also swap the Z1 and Z2 motors and end stops at the control board and the machine will continue as normal, and you can see if the problem follows the motor, or the board/driver. If it follows the motor, it is most certainly wiring. If it follows the driver, could be other things.

I am not familiar with the Gen L v2.1, I had a Gen L v1.0 on my Primo for a while. The 2.1 seems to suport the TMC drivers. Which drivers are you using? The TMC drivers have a thermal protection mode if they get hot, and can shut down. The V1 RAMPS firmware in the marlinbuilder releases may not have the driver current set but I believe it otherwise works.

1 Like
  1. No, the movement is completely wrong. E.g., a 100mm movement in proterface makes the machine moves about 50% of it
  2. I did not try to reset the board, what i have done was unplugging it from the powersource and then powering it on. It seems to fix the issue 100% of times.
  3. I’m not sure, I just observed it in the first start after the machine is powered off for a long period.
  4. It goes slowly at the machine movement (e.g., homing). I did not try to cut when the machine is slow

I have ordered the BTT TFT 35, waiting to use it with SD.

I have done the swapping thing with the Z1 and Z2 motor wires and their respectives endstops. I tried two times, and the problem seems gone. But tomorrow I will use the machine and keep a look if it really solved the issue.

It seems that I really have to plug a fan in the board, currently I’m running it without one.

Thank you for your responses.

It sounds to me like a brown-out condition where there isn’ t enough power. Whether that is from the motor power supply or the USB to the board, I would suggest checking your power voltage when it goes slow And verifying your power supply or computer system isn’t part of the problem.

1 Like